Hope Pro II Rear Hub Squeak-- Mtbr.com
Results 1 to 5 of 5
  1. #1
    Rider and Wrench
    Reputation: knottshore's Avatar
    Join Date
    Jan 2008
    Posts
    1,478

    Hope Pro II Rear Hub Squeak-

    I have a close to new set of Hope hubs and after a ride I cleaned and lubed every thing up and noticed a squeak and after a bit of searching found that it was in the hub. With the wheel removed and spinning on either the skewer or holding the end caps you can hear a faint squeak, I removed the end caps and everything looked clean but I wiped it all out and put it back together (used some light lube on the o rings). Still squeaking, but I cannot imagine the bearings being bad this soon not but a few months of use?

    Short of replacing all of the bearings can anyone shed some light on this- it is driving me crazy!
    I Just wish I could ride more!


  2. #2
    mtbr member
    Reputation:
    Join Date
    Feb 2006
    Posts
    25
    Same here; I got a new Hope II rear hub which, after a couple of rides (one of them was a long 5 hour long ride in pouring rain), started to squeak. After a close inspection I've decided that it's a plastic / rubber kind of squeaking, not a metallic one; also, I've almost rebuilt that wheel (tighten / loosen all the spokes to get an even spoke tension) - the process took a very long time, as I'm not too good - during which I kept hearing that squeak - definitely not a metallic kind of squeak.
    So I've decided to ignore the squeak, didn't even bother to check the hub internals.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Dec 2008
    Posts
    44
    I had the same problem, turned out the bearing was finished. Try taking them out and turning each one to see if they are the problem.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Feb 2006
    Posts
    25
    Quote Originally Posted by alexalecu
    Same here; I got a new Hope II rear hub which, after a couple of rides (one of them was a long 5 hour long ride in pouring rain), started to squeak. After a close inspection I've decided that it's a plastic / rubber kind of squeaking, not a metallic one; also, I've almost rebuilt that wheel (tighten / loosen all the spokes to get an even spoke tension) - the process took a very long time, as I'm not too good - during which I kept hearing that squeak - definitely not a metallic kind of squeak.
    So I've decided to ignore the squeak, didn't even bother to check the hub internals.
    I have just finished rebuilding my Hope Pro II rear hub.
    Found out that one of the bearings had lots of drag and was making a horrible noise when rotating, so the squeak was coming from that one for sure.

    Next time I'll hear such noises coming from the rear hub, I will definitely check the bearings.

  5. #5
    mtbr member
    Reputation:
    Join Date
    Mar 2016
    Posts
    16
    I have brand new Fortus wheels on my gravel bike. Started hearing squeak in front hub. I only washed it once so far with water. I'm suspecting the bearings are dry and need to be packed with grease. I had same issues with Hope F20 pedals. They were clicking like crazy out of box. Opened them up and both were bone dry. I'm not sure if they are greasing things well at Hope during assembly.

Members who have read this thread: 10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2020 VerticalScope Inc. All rights reserved.