Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation: maverickc_c's Avatar
    Join Date
    Nov 2009
    Posts
    179

    SRAM X1 11 speed shifting problems

    Hey guys, my derailleur is not shifting well under load. I was riding on Weds. and it started acting up so I finished the ride and put in on the stand. I adjusted the cable tension and it worked great on the stand going thru all the gears. Rode around the neighborhood and it shifted ok but after shifting to smallest cog the shifter still had one position to go. When shifting to the next larger cog it took two clicks for it to move up. I shifted thru all the gears and back down. Same problem. Put it back on the stand and it works great. No extra clicks. Any suggestions? BTW I also posted in drive train
    2015 Pivot Mach 429 Carbon
    2008 Specialized Roubaix Expert

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jul 2017
    Posts
    931
    What about the limit screws?


    Sent from my iPhone using Tapatalk

  3. #3
    mtbr member
    Reputation: maverickc_c's Avatar
    Join Date
    Nov 2009
    Posts
    179
    The limits are set per sram guidelines. The smallest cog is slightly inboard of the jockey wheel. I tried moving it so it was centered but that caused other issues.
    2015 Pivot Mach 429 Carbon
    2008 Specialized Roubaix Expert

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jul 2015
    Posts
    829
    Sounds like it's a gunked up cable or bent hanger if indexing is going off multiple gearsultiple gears into cassette.
    Quote Originally Posted by maverickc_c View Post
    The limits are set per sram guidelines. The smallest cog is slightly inboard of the jockey wheel. I tried moving it so it was centered but that caused other issues.
    Sent from my XT1585 using Tapatalk

  5. #5
    mtbr member
    Reputation: maverickc_c's Avatar
    Join Date
    Nov 2009
    Posts
    179
    I hate to admit it but I caused the problem. You guys were close about gunked up cables and that got me thinking. I had put a velcro strap around my top tube and three cables that were slapping my rear shock. Once I took it off and re-tuned, it worked fine.
    Thanks!
    2015 Pivot Mach 429 Carbon
    2008 Specialized Roubaix Expert

Similar Threads

  1. Shifting problems with XT 9 speed RD, SRAM PG-950 Cassette and Deore M590 Shifters
    By dhimandeydip in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 5
    Last Post: 06-26-2017, 10:14 AM
  2. Sram XX1 - shifting problems on just two cogs, rest fine
    By chnow in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 10
    Last Post: 07-08-2014, 01:07 PM
  3. Replies: 2
    Last Post: 06-26-2014, 12:24 PM
  4. shifting problems- Sram X0
    By ehigh in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 6
    Last Post: 05-26-2012, 12:14 PM
  5. SRAM X-7, 9-speed, mid cage shifting problems?
    By slopefish in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 0
    Last Post: 03-18-2012, 08:09 AM

Members who have read this thread: 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.