Ping....- Mtbr.com
Results 1 to 5 of 5

Thread: Ping....

  1. #1
    Single Speed Junkie
    Reputation: crux's Avatar
    Join Date
    Jan 2004
    Posts
    3,111

    Ping....

    Have been having some unusual noises from the single speed lately and I'm sure that it is not my knees.

    When really cranking it sounds as if the chain is jumping teeth if you were on a geared bike. The chain is tight and running a blackspire 32 tooth front ring Ti White Industries 17 tooth freewheel and an Izumi Super V track chain. Frame is Ti with set screws on a Philwood EBB and Raceface Next crankset. Cant really think of where the problem is steming from but it is getting anoying.

    Also was having an issue with dropping the chain even though it was tight and cant figure that one out for the life of me.

    Chain line is spot on as well one of the first things that I checked.

    Any advice from the gurus out there?

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jan 2005
    Posts
    660
    Check your chainring. I had a bent chainring that was throwing my chain relentlessly until I discovered it.
    -jon

  3. #3
    mtbr member
    Reputation:
    Join Date
    Feb 2004
    Posts
    1,410
    Freewheel pawls could be going as well

  4. #4
    mtbr member
    Reputation: extrmtao's Avatar
    Join Date
    Mar 2006
    Posts
    2,277
    I had this problem recently and it was because my freewheel hub was going going gone. New set of wheels did the trick.

  5. #5
    large member
    Reputation: mud'n'sweat's Avatar
    Join Date
    Feb 2006
    Posts
    1,838
    I'm having this exact same issue, and my whole hub/freewheel is brand new.
    #1 NORBA elite singlespeed toolbag 30-34 age group

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.