TALAS adjustment not working- Mtbr.com
Results 1 to 6 of 6
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2004
    Posts
    358

    TALAS adjustment not working

    So I have a 2008 Fox 32 RL, and the TALAS isn't working... Sometimes, it'll go down to 120, but it doesn't go down to 100 anymore. Anyone have any suggestions? Thanks!
    Let's all start a mrsalty is a whiny biatch thread...

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jul 2008
    Posts
    130
    had the same thing happen on my '09.

    don't know if they're serviceable, so i had to send mine back to Fox to have it replaced.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Oct 2004
    Posts
    358
    That may not be that bad, only if I get an 09 out of it!!!
    Let's all start a mrsalty is a whiny biatch thread...

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    225
    have it serviced and retimed no problem at all simple in fact.

  5. #5
    mtbr member
    Reputation:
    Join Date
    Oct 2004
    Posts
    358
    But the thing is, is that it only has like 200 miles on it (not that many for a trail bike) It shouldn't be acting up like this. I take good care of it. I'm not saying that I don't ride it hard, but it's never been in a major crash, and the oil levels and stanchions are spot-on.
    Let's all start a mrsalty is a whiny biatch thread...

  6. #6
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    225
    What model year do you have?

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.