NiteRider Sol Charging issue- Mtbr.com
Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: amillmtb's Avatar
    Join Date
    Jun 2005
    Posts
    2,423

    NiteRider Sol Charging issue

    I am having a problem with my Niterider Sol light and the charging process. When I plug in the charger the red "charging" light turns on, but goes off after about 5-10min even though the battery is still plugged in. I recently got a new charger because I misplaced the original, but it is the same one (Sol/SolMate). Has anyone else had this problem with your light? If so, how did you fix it?

    Thanks for your help!

  2. #2

    Reputation:
    Join Date
    Sep 2009
    Posts
    1
    I have the exact same problem. Unit worked great last year, but after summer storage I'm only getting a light indicator for the first 15 min after connecting to charger. If I leave battery on charger for full 8 hrs I only get about 20 min of light output then fades quickly.
    I have contacted NR and waiting for response. From everything I read on their site, this battery does not need any conditioning.

  3. #3
    mtbr member
    Reputation: zen bicycle's Avatar
    Join Date
    Mar 2007
    Posts
    463
    If it is a NIMH battery and It sat unused all summer it could be dead. If li_ion it could be the PCB or a dead cell causing the charger to think it is charged.

    Either way sounds like a new battery pack is in the future for you.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.