Niterider pro 1200 problem- Mtbr.com
Results 1 to 4 of 4
  1. #1
    Blind biker
    Reputation: harry2110's Avatar
    Join Date
    Oct 2008
    Posts
    301

    Niterider pro 1200 problem

    I have had a problem that if I unplug my lights accidently while they're on or sometimes just plugging them in, the lights seem to short out and wont turn back on till I put the battery back in the charger. Also the battery gauge isnt working and is staying on red but will run for hours.

  2. #2
    Goats Rule!
    Reputation:
    Join Date
    Sep 2007
    Posts
    348
    I've had the same thing happen to my pro1200 where the light quit working until the battery went back in the charger. Happened to a friend too and he took the light/battery back to NiteRider. They told him to just stick the battery on the charger if it happened again.

    Don't know about the red battery state indicator, but try running the battery down all the way and then charging it. Might re-calibrate whatever electronics are in there.

  3. #3
    Blind biker
    Reputation: harry2110's Avatar
    Join Date
    Oct 2008
    Posts
    301
    He might want to send it back as I just called them and they said to send it in. Maybe its becuase I work at a dealer and they dont want bad press or what? ive done the discharge recharge already a couple times and its still red.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Nov 2009
    Posts
    1,462
    NiteRider has always had one of the best beam patterns in the bike lighting industry due to the best reflectors out there. That been said, I still don't get why there there battery's/chargers remain one of the most unreliable in the buisness.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.