NiteRider MiNewt500 Still "glows" when off!!! (Pic) SHOULD I RETURN?- Mtbr.com
Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation: JMP0323's Avatar
    Join Date
    Mar 2012
    Posts
    158

    NiteRider MiNewt500 Still "glows" when off!!! (Pic) SHOULD I RETURN?

    I purchased a NiteRider MiNewt500 Light from Performance Bike. It works great, the only issues (I think it is a issue) is when I turn the light OFF or LOCK the light. The little square light still glows and has not turned off since I turned it on for the first time. I am afraid it could be draining my battery even when the light is off/locked.

    Does anybody that owns these have this issue with the light still glowing minimally when it is off? I can return it to my local Performance Bike. But I want to make sure it is not a known issue.


    I called NR and he said that it wasn't normal and it might drain my battery when it is off. He said to watch it for a few days and see if it goes away. It has been 3 days and this glow has not gone away.
    Attached Thumbnails Attached Thumbnails NiteRider MiNewt500 Still "glows" when off!!! (Pic) SHOULD I RETURN?-photo-1-.jpg  

    What did you put in that sandwich?

  2. #2
    mtbr member
    Reputation: ecub's Avatar
    Join Date
    Sep 2011
    Posts
    457
    Lights that do not turn off when you turn it off is DEFINITELY not normal. I have a the MiniNewt Dual 700 and they do not do that at all. I'd say go to Performance and exchange it.

    Sent from my Transformer Prime TF201 using Tapatalk 2
    - Ed

    2012 Trek Madone 6.7 SSL
    2013 Specialized Tricross Comp Disc
    2011 Trek Top Fuel 9.9 SSL
    2012 Salsa Mukluk 2

  3. #3
    mtbr member
    Reputation: JMP0323's Avatar
    Join Date
    Mar 2012
    Posts
    158
    ^ I am going to return it. It does seem to be draining my battery when off. I fully charged it. Then unplugged it and let it sit for a few hours. Then plugged it back in and it seemed to be low cause it charged with the red light on for another 2 hours!!!
    What did you put in that sandwich?

  4. #4
    mtbr member
    Reputation:
    Join Date
    May 2012
    Posts
    29
    Unfortunately it seems you got a defect. I've got 2 minewt 600's and when they are "off" they are "off"

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.