Magicshine Durability?- Mtbr.com
Results 1 to 15 of 15
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jan 2004
    Posts
    988

    Magicshine Durability?

    I love all of the MS threads! My concern is this. I have head light and tail light and they both mount the same way, with the cord placed too close to the o ring when it's mounted. I change to a different o ring size daily and I am worried that this will cause durability issues with the cable going into the light. Does anyone have any long term use in this type of condition with either the head or tail light?

    Thank you.

    Chris

  2. #2
    mtbr member
    Reputation:
    Join Date
    Mar 2004
    Posts
    826
    I too have wondered the same thing, since the O ring bends the power cable.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jun 2009
    Posts
    45
    I bought one and the charger system failed within a few days. I just went with the Lupine Betty II. I considered keeping MS as a secondary light for another bike, but not impressed with the battery holder or charging system. Lamp is really not too bad for the price. If I got one again, I would just consider just the lamp itself and build my own battery pack and use a better charger.

    I am having issues getting my refund processed. The unit was returned over three weeks ago and still waiting for CC refund. Contacted GEOMAN 8/28and they said would refund, but still not showing up yet. A little concerned and seems unduly long and not the great customer service I was expecting from forum comments.
    Last edited by skoor; 09-02-2010 at 09:51 PM.

  4. #4
    Pimpmobile
    Reputation:
    Join Date
    Mar 2010
    Posts
    487
    Wow...

    I guess you decided to drop some coin, huh?



    VERY surprising on the Geoman customer service thing... I had a warrantee rerplacement within two days.
    "Fear not the ob-stackles in your path"

  5. #5
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    1,106
    Quote Originally Posted by HamfisT
    VERY surprising on the Geoman customer service thing... I had a warrantee rerplacement within two days.

    If he'd gone with a warrenty replacement, he probably would have had that in 2 days too, but perhaps a credit card refund takes longer (on the banks end).

  6. #6
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    1,106
    Quote Originally Posted by ctxcrossx
    I change to a different o ring size daily and I am worried that this will cause durability issues with the cable going into the light.

    I'm curious why you change the O-ring size daily? I don't follow?

    Anyway, you can look at post #11 in this thread to see if they might work for you.

  7. #7
    mtbr member
    Reputation:
    Join Date
    Mar 2006
    Posts
    24
    I have the MS 900. I've never used the supplied o rings. Instead, I use an old Sigma sport o ring which is a little thinner so it doesn't interfere with the power cable.

  8. #8
    mtbr member
    Reputation:
    Join Date
    Jan 2004
    Posts
    988
    Quote Originally Posted by fightnut
    I'm curious why you change the O-ring size daily? I don't follow?

    Anyway, you can look at post #11 in this thread to see if they might work for you.
    I mainly change out the tail light as that gets used more. I have a one year old son and we go out in the bike trailer or running stroller daily. It really helps with visibility on the road. Sometimes both, so it moves depending on which we are using. I also commute by bike, so it gets used there as well. It's not uncommon to move the tail light 2-3 times a day.

    I was worried about the wear and tear on the cable going into the housing, which happens to be identical with the headlamp. I do have a solution for both parts though. I'll try to post an update tonight.

    Chris

  9. #9
    Dirt Deviant
    Reputation: savagemann's Avatar
    Join Date
    Jan 2008
    Posts
    3,694
    I had a handful of some niterider o rings. I use those as they are smaller and you dont have to bend the cable up to get it in there.
    I also modded my 1400 with a marwi mount so I completely ditched the o rings on the bars. Mount works great.
    Look, whatever happens, don't fight the mountain.

  10. #10
    mtbr member
    Reputation:
    Join Date
    Jun 2009
    Posts
    45
    Quote Originally Posted by HamfisT
    Wow...

    I guess you decided to drop some coin, huh?



    VERY surprising on the Geoman customer service thing... I had a warrantee rerplacement within two days.
    Not as much as you would think, I got a good deal. But still several times morel

    Maybe I am the first to ever return one. I actually did consider keeping it, but the darn thing charged once and then just nothing. I just noticed over in the bike rack forums some comments about 1UPUSA and its bad customer service. Just the opposite on my several interactions and have have been extremely pleased. Perhaps we suspect too much of these smaller companies. They probably have limited staff with schedule/vacations issues. What looks bad to us, if probably their best they can do with limited resources.
    Last edited by skoor; 09-04-2010 at 12:48 AM.

  11. #11
    Chunky Monkey
    Reputation: circusubet's Avatar
    Join Date
    Aug 2006
    Posts
    413

    Still Going

    Had my MS since '09 and still going strong......

    Thx,
    John
    Lurkers Unite! Never mind....

  12. #12
    mtbr member
    Reputation: TwoHeadsBrewing's Avatar
    Join Date
    Aug 2009
    Posts
    2,949
    I've run my MS900 since last October, commuting through the winter rain or shine. I've also used it a dozen times so far this year on MTB night rides and it's stood up to that as well. I even crashed with it on my helmet and it still works fine. I've had zero problems so far, and the battery life is still good.

    On that topic, how good are the 81650 cells in the MS battery packs? What's the expected life of those types of Lithium Ion rechargeables?
    "Got everything you need?"

  13. #13
    ol' dusty lungs
    Reputation: the sloth's Avatar
    Join Date
    Aug 2007
    Posts
    206
    Purchased in October '09... went to fire it up this year and light would shut off unexpectedly... tracked it down to a bad connector on the battery pack.

  14. #14
    mtbr member
    Reputation: Pitto's Avatar
    Join Date
    Sep 2005
    Posts
    520
    first proper use this morning of my MS900 and i must say, its a great value light.

    i used it solo helmet mount, and found it to be great, but i feel, it should be paired up with a
    bar mounted one also.

    still, it does the job. just need to get some spare o-rings from the bearing shop and chuck them in the hydropac.

  15. #15
    Chunky Monkey
    Reputation: circusubet's Avatar
    Join Date
    Aug 2006
    Posts
    413

    Yep

    Quote Originally Posted by Pitto
    first proper use this morning of my MS900 and i must say, its a great value light.

    i used it solo helmet mount, and found it to be great, but i feel, it should be paired up with a
    bar mounted one also.

    still, it does the job. just need to get some spare o-rings from the bearing shop and chuck them in the hydropac.

    P-+1
    Thx,
    John
    Lurkers Unite! Never mind....

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.