Magicshine Battery wont Charge Past 7.4v- Mtbr.com
Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation:
    Join Date
    Feb 2007
    Posts
    643

    Magicshine Battery wont Charge Past 7.4v

    Seems like my Magicshine battery pack wont charge past 7.4v. The LED on the charger turns green and the battery measures around 7.4v. I went out riding a couple of days ago with it and the light died around 45min into the ride. I know its lasted way longer than that before. My two 18650 flashlights were still going strong and they die much earlier than the Magicshine. Is it the batteries, charger or the battery controller board?

    Anyone else have this issue? Any ides on how to fix it?

    thnx

    Edit: don't think it's the charger, just tested it and it's putting out 8.39v

  2. #2
    Dirt Deviant
    Reputation: savagemann's Avatar
    Join Date
    Jan 2008
    Posts
    3,694
    How old is the battery?
    Look, whatever happens, don't fight the mountain.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Feb 2007
    Posts
    643
    Quote Originally Posted by savagemann
    How old is the battery?

    It's around 10 months old.

    Just tested it out and it died around 45minutes on high, next to a fan. The battery pack shows 0v after it died; guess that's the circuit protection working.

    The cells are probably gone. I wish Magicshine or someone made a battery pack that allows one to just replace the cells; I have a bunch I used on the torches. Sure there are the DIY but that's too much of a pain.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.