Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Apr 2010
    Posts
    642

    Ibis Rear Hub-Potential issue??

    Can you guys check something out for me please? First pic is of the Ibis rear hub non-drive side. Second pic is drive side. The axle on the non-drive side has the silver knurled surface and the drive side does not. Is it supposed to? I suspect it does and think it has fallen off.

    Please check ASAP. Thanks.
    Attached Thumbnails Attached Thumbnails Ibis Rear Hub-Potential issue??-nondrive-side-hub.jpg  

    Ibis Rear Hub-Potential issue??-drive-side-hub.jpg  


  2. #2
    mtbr member
    Reputation:
    Join Date
    Jul 2006
    Posts
    1,440

    it's OK

    Yup, that's normal.

    It needs the wrench flats on the drive side so you can get it apart but those flats make it very hard to put a knurled ring on it. Fortunately, because it's a through axle the knurling wouldn't be doing much anyways.

    Colin via Hans

  3. #3
    mtbr member
    Reputation:
    Join Date
    Apr 2010
    Posts
    642
    Thanks for the response. Yup, went to the lbs to double check this morning. Freaked out there for a minute. Had some play and thought this may have been the cause.

  4. #4
    bike rider
    Reputation: Lelandjt's Avatar
    Join Date
    Feb 2008
    Posts
    5,262
    What hub is that?
    Keep the Country country.

  5. #5
    mtbr member
    Reputation:
    Join Date
    Oct 2008
    Posts
    10
    Quote Originally Posted by Lelandjt
    What hub is that?

    They are Ibis hubs. OEM is Joytech I believe.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.