Results 1 to 10 of 10
  1. #1
    mtbr member
    Reputation:
    Join Date
    Mar 2007
    Posts
    76

    Headset Installation - Mojo **Fixed now. Thanks

    Hello. I just got an 08 Mojo frame. The headset I am trying to put in is an FSA Orbit IS. I'm having a little trouble with the installation. I've got the race on and bottom bearing. When I put the top bearing on the fork, it wants to slide all the way down the headtube (even with the compression ring on) until it touches the bottom one. I was finally able to get it to stay up top, but I don't know how reliable it is going to be when I'm riding. It seems like there should be a lip or something that prevents it from sliding all the way down. Supposedly, this headset was used in this frame before, so I don't think I've got the wrong size. Am I just missing something? Or do I maybe have the wrong size headset? Thanks.
    Sam
    Last edited by RotarySam; 06-25-2008 at 06:45 PM.

  2. #2
    mtbr member
    Reputation:
    Join Date
    May 2004
    Posts
    236
    pics??

  3. #3
    mtbr member
    Reputation:
    Join Date
    Mar 2007
    Posts
    76
    I can post some tonight if that will help.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Dec 2005
    Posts
    2,440
    Quote Originally Posted by RotarySam
    Hello. I just got an 08 Mojo frame. The headset I am trying to put in is an FSA Orbit IS. I'm having a little trouble with the installation. I've got the race on and bottom bearing. When I put the top bearing on the fork, it wants to slide all the way down the headtube (even with the compression ring on) until it touches the bottom one. I was finally able to get it to stay up top, but I don't know how reliable it is going to be when I'm riding. It seems like there should be a lip or something that prevents it from sliding all the way down. Supposedly, this headset was used in this frame before, so I don't think I've got the wrong size. Am I just missing something? Or do I maybe have the wrong size headset? Thanks.
    Sam
    huh? i think i am missing something

    mx

  5. #5
    mtbr member
    Reputation:
    Join Date
    May 2004
    Posts
    236
    Quote Originally Posted by RotarySam
    I can post some tonight if that will help.
    sure would... cos what you're describing doesn't add up..

  6. #6
    mtbr member
    Reputation:
    Join Date
    Mar 2007
    Posts
    76
    Ok. I figured it out. The frame was shipped with some plastic plugs covering the top and bottom of the headtube. I just looked at the plugs, and one of them had pulled the metal sleeve out with it that goes on the top of the headtube. That metal sleeve holds the top part of the headset up. That is why it was just sliding down to the bottom. So, I WAS missing something.. haha. All is good now. Thanks for your time.
    [08 Ibis Mojo Carbon]

  7. #7
    mtbr member
    Reputation:
    Join Date
    Dec 2005
    Posts
    2,440
    Quote Originally Posted by RotarySam
    Ok. I figured it out. The frame was shipped with some plastic plugs covering the top and bottom of the headtube. I just looked at the plugs, and one of them had pulled the metal sleeve out with it that goes on the top of the headtube. That metal sleeve holds the top part of the headset up. That is why it was just sliding down to the bottom. So, I WAS missing something.. haha. All is good now. Thanks for your time.
    have fun assembling your new bike!

    mx

  8. #8
    mtbr member
    Reputation:
    Join Date
    May 2004
    Posts
    236
    HOLD UP COWBOY!!!
    It is a Mojo Classic or SL you're building up...
    It sounds like a Classic, cos the SL has carbon races. That "metal lug" sounds like the upper bearing race. It's meant to be bonded to the headtube.
    You'd better give Ibis a call and have a chat to them..

  9. #9
    mtbr member
    Reputation:
    Join Date
    Mar 2007
    Posts
    76
    Quote Originally Posted by littlejohn
    HOLD UP COWBOY!!!
    It is a Mojo Classic or SL you're building up...
    It sounds like a Classic, cos the SL has carbon races. That "metal lug" sounds like the upper bearing race. It's meant to be bonded to the headtube.
    You'd better give Ibis a call and have a chat to them..
    It's a regular Mojo. Yeah, I know it's supposed to be bonded to the headtube. I took care of it. I'm not worried.
    [08 Ibis Mojo Carbon]

  10. #10
    mtbr member
    Reputation:
    Join Date
    Sep 2007
    Posts
    1,135
    It's a regular Mojo. Yeah, I know it's supposed to be bonded to the headtube. I took care of it. I'm not worried.
    jbweld to the rescue !
    http://jbweld.net/index.php

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.