PSA: Specialized Levo Turbo wiring harness failure- Mtbr.com
Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Apr 2004
    Posts
    145

    PSA: Specialized Levo Turbo wiring harness failure

    Hi All. I have a 2016 Specialized Levo Turbo Expert I bought on the secondary market.

    I've had an intermittent problem where the motor would seem to lose power intermittently. It was very subtle at first - almost as if the power was changed to eco by itself. The the motor would cut out completely here and there. Then it failed completely.

    I was very worried at the prospect of an expensive repair (correct me if I'm wrong, but I believe the Specialized warranty only applies to the original purchaser).

    I did some troubleshooting and, as it turns out, one of the female connectors on the wiring harness to the battery some how got stretched out/compromised. I put a piece of alum foil in there and, wallah! Fixed and the motor was back to consistent full power.

    See pic. As having a piece of foil is probably not best practice I've put in a request to my LBS to order a new harness. Still no word of ETA or price. Nevertheless, hope this post helps someone out.

    PSA:  Specialized Levo Turbo wiring harness failure-harness.jpg

  2. #2
    mtbr member
    Reputation:
    Join Date
    Nov 2018
    Posts
    2
    camus! Thank you, it worked!

    thanks for posting this - my levo expert is about 800 miles in, and was just cutting out... very frustrated was not enough to express my disappointment.... and, to my delight, your solution worked! when i inspected the harness and the female holes, i noticed they were wallowed out... your aluminum foil solution was the trick and i will always carry a wade in my camelback from now on. thanks again. oldfatdudenicebike

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jun 2017
    Posts
    5
    Ive got a cable ordered. There is a UK group selling a slightly longer one for 75. Ill try the foil in the meantime. Click below for the link...

    https://www.freeborn.co.uk/specialized-turbo-levo-motor-to-battery-harness
    Last edited by Henry Hester; 11-26-2018 at 11:04 AM. Reason: Correction

  4. #4
    mtbr member
    Reputation:
    Join Date
    Nov 2018
    Posts
    2
    Henry, can you let us know if the longer cable worked out please - ofd

  5. #5
    mtbr member
    Reputation:
    Join Date
    Jun 2017
    Posts
    5
    Yes, its a little looser. Its a in the tool box spare part yall need. Your LBS will either warranty or sell you one for about $100. If they warranty and install, MAKE SURE they dont route the cable through the holding clip. Use the clip to zip-tie the cable to the side. The clip is too tight and somehow pinches the cable into not communicating between battery and motor. Against Guru Chris at UK Berkshire Cycles, I actually eliminated the clip post and let the cable hang. Carry a spare for you and loved ones in need.
    Last edited by Henry Hester; 01-20-2019 at 11:46 AM. Reason: Correction

Similar Threads

  1. Replies: 376
    Last Post: 11-03-2019, 07:51 AM
  2. Dancing with the Devil (Specialized Turbo Levo Demo)
    By Neldar in forum California - Norcal
    Replies: 208
    Last Post: 08-31-2017, 07:46 PM
  3. Specialized Turbo Levo impressions
    By fc in forum E-Bikes
    Replies: 46
    Last Post: 07-12-2017, 03:11 AM
  4. Replies: 1
    Last Post: 09-21-2016, 02:59 AM
  5. Replies: 64
    Last Post: 04-22-2016, 08:40 AM

Members who have read this thread: 1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2020 VerticalScope Inc. All rights reserved.