Crank Issue- Mtbr.com
Results 1 to 6 of 6

Thread: Crank Issue

  1. #1
    ----------------
    Reputation:
    Join Date
    Aug 2006
    Posts
    59

    Crank Issue

    I've got an 07 sx trail and I'm having issues with the hussefelt cranks that came on it. The crankbolt on the drive side keeps coming loose. I've read that people have had the same issues but I was wondering if there is a way to fix the problem. Thanks.
    "Roads? Where we're going, we don't need roads."

  2. #2
    clyde in training
    Reputation: 08nwsula's Avatar
    Join Date
    Oct 2005
    Posts
    1,917
    loctite

  3. #3
    moaaar shimz
    Reputation: tacubaya's Avatar
    Join Date
    Jan 2006
    Posts
    9,117
    Blue* loctite

  4. #4
    ----------------
    Reputation:
    Join Date
    Aug 2006
    Posts
    59
    Thats what i was thinking but i wasnt sure it would be safe to use. thanks.
    "Roads? Where we're going, we don't need roads."

  5. #5
    Meh.
    Reputation: XSL_WiLL's Avatar
    Join Date
    Nov 2004
    Posts
    17,508
    Make sure to clean the surfaces that the loctite will be applied to.

  6. #6
    DIRTYAMERICAN
    Reputation:
    Join Date
    Apr 2004
    Posts
    334
    Do you have external bearings on your bottom bracket? If you do LOOSEN the non drive side first, THEN tighten the drive side, use locktite if necessary, THEN tighten the nondrive side. This will allow you to fully tighten the drive side. I had this problem just recently and being new to external bearing bbs (yes, I know I'm behind the times but I don't buy new parts until they break) ..I just learned on my own what's up with them.
    let's roll

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.