Wheezy RP23 on XCL?- Mtbr.com
Results 1 to 3 of 3
  1. #1
    Mmmm Rocks Good
    Reputation:
    Join Date
    Feb 2005
    Posts
    645

    Wheezy RP23 on XCL?

    I've got a fairly new XCL (Jan 08) and I opted for the RP23 shock. I notice that when the shock is really being worked hard in rock gardens, lots of continuous hits, things like that, that the shock makes a high pitched wheezing noise on big hits? I am thinking it is the oil going through the various ports or shims when the oil is hot. I noticed it does not make this same noise when the shock is cooler? Anybody else experience this? I don't think the shock is defective because it works properly. Just more curious than anything? I almost wish I had gone w/the other shock w/the piggy back resorvoir?

  2. #2

    Reputation:
    Join Date
    Jan 2004
    Posts
    449

  3. #3
    Mmmm Rocks Good
    Reputation:
    Join Date
    Feb 2005
    Posts
    645

    I think Darrin nailed it

    Quote Originally Posted by slowride
    THANK YOU!!!!
    I believe Darrin at Push nailed it? Basically it is the same explanation that Romic gave me when their shock did the same thing a few years ago. Funny how I have 2 shocks doing the same thing years apart. Must be my tank a$$ causing it! Since the shock is so new I am not going to change the seals yet but will monkey w/the PP settings.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.