Front Lever on Disc Brake with No Pressure- Mtbr.com
Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jan 2006
    Posts
    78

    Front Lever on Disc Brake with No Pressure

    Okay, I was just setting up my new Shimano XT disc brakes on my bike. The rear brake adjusted easily, but the front brake was rubbing. I tried adjusting the caliper, but I couldn't get the rubbing to stop. I did some research and discovered that Shimano hydraulic discs can be bled slightly out the lever. So I opened the reservoir, then pressed on the pads a bit to release a bit of fluid. A small amount of mineral oil came out, and I replaced the reservoir seal and cap. When I reinstalled the wheel and tried the brake, I had no lever pressure at all. What did I do? How do I fix it?

  2. #2
    Livin the Dream
    Reputation: Flatfoot's Avatar
    Join Date
    Jun 2010
    Posts
    42
    Sounds like you got air into the system. Even a very small amount of air can lead to a mushy feel at the lever. The system needs to be bled. I have never done Shimano brakes before, so maybe someone else can jump on here and help you out, or check online.

  3. #3
    mtbr member
    Reputation: rzims's Avatar
    Join Date
    Sep 2005
    Posts
    1,098
    I just installed the XT brakes on my SS and Park tool has a good article on bleeding them on their site - click here

  4. #4
    Linoleum Knife
    Reputation: forkboy's Avatar
    Join Date
    Apr 2004
    Posts
    3,324
    Quote Originally Posted by Jayzonk
    How do I fix it?
    Pump the lever a few times.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.