Problem with Pearl Izumi shoes- Mtbr.com
Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jan 2006
    Posts
    78

    Problem with Pearl Izumi shoes

    Hey Guys,
    Just wondering if I could get some feedback on my shoe problem. I got new Pearl Izumi shoes for my clipless pedals, and I've been using them for a couple of weeks now. Today, on my way home, I couldn't get my left foot out of the pedal. I loosened the binding adjusters until I could manage to free the shoe. This has happened TWICE now! After examining the shoe, it looks like a couple of things are going on:
    1) the tops of the posts for the screws in the shoes have broken off
    2) the cleats aren't staying in one spot
    3) I'm MISSING a screw (literally)
    4) Another screw has come loose, and appears misthreaded

    I've never had trouble like this with my road shoes. Should this be happening? Should I contact Pearl Izumi? Or should I get some Specialized shoes? Sidi? I need good shoes, or this is gonna be one frustrating commuting season!

  2. #2
    SS Rider
    Reputation: peanut09's Avatar
    Join Date
    Apr 2005
    Posts
    207
    Sounds to me like the shoes are fine and you just need a new plate. Whoever installed the cleat on the bottom of your shoe tightened the screws to tight and broke the plate. Very common and can happen with any shoe. I have a pair of Pearl Izumi shoes and it is real easy to replace.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jan 2006
    Posts
    78
    I put the cleats in myself - didn't think I overtightened them, but maybe I did.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.