Problem mounting !#$%^&* prowler SL- Mtbr.com
Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation:
    Join Date
    Sep 2007
    Posts
    51

    Problem mounting !#$%^&* prowler SL

    OK, just got a first flat on a WTB Prowler SL on my first 29er bike, not even 4 rides on it. Cannot get the tire mounted on a Salsa Semi 29er rim without pinching the tube. Never had a problem in all my years with 26" but what the heck? I lathered the bead with soapy water (like I used to do with auto tires) but still difficult to mount. What am I not doing right (while my bike sits with one wheel on)?

  2. #2
    mtbr member
    Reputation:
    Join Date
    Aug 2007
    Posts
    4,667
    Put one bead on, stick the tube in with just a little air. Push bead that's already on the rim into the center channel. Push the other bead on. When you get to the tight spot go back and push the bead into the center channel so that it can go up higher and you can push the bead over the rim. If the tube is getting pinched just run with it. Get the bead on then take a tire lever and work the tube under the tire. Just hook it under the bead and pry a little as if you were going to take it off.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Sep 2007
    Posts
    51
    Thanks - that worked. Never had to mess with it as much with the Nevegals.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT MTBR

VISIT US AT

© Copyright 2019 VerticalScope Inc. All rights reserved.