Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2011
    Posts
    127

    Easton EA70 XC hub problem

    Hi all.
    I recently purchased a set of Easton EA70 XC 29er wheels.
    They are nice, true and the tension is great but the very first ride came back with a concern.

    I've put about 70miles on the wheels now and the problem is intermittent and happens every few miles. Basically, when I coast and then continue to pedal, sometimes there is a loud crackle from the rear wheel, with also the cranks skipping a bit. It only happens under fairly light load. I'm suspecting that it's the freehub not engaging right away and skipping some teeth before it engages but can't tell you that this is it for sure.

    the wheels have Easton's X2 hubs.
    Is this something to worry about? I don't want to get stuck in the woods when the hub explodes but my warranty options seem to be limited as the wheels were purchased online from what appears not to be one of the official Easton's dealers.

  2. #2
    mtbr member
    Reputation:
    Join Date
    Oct 2011
    Posts
    127
    anyone?

  3. #3
    mtbr member
    Reputation: jjmtb1's Avatar
    Join Date
    Jul 2008
    Posts
    269
    Take them apart and see if anything catches your attention or to a take thm to a shop.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Oct 2011
    Posts
    127
    Ok. so the issue is finally fixed after 2 services.
    first the LBS serviced it and got an entirely new cassette body from easton. This didn't help so month later the shop sent out the entire wheel to Easton.

    it took them 30 days to fix it but finally they rebuilt the entire rear hub with new internals and the noise is gone so far.
    I put about 50 miles on it since service and I hear no noises.

    fingers crossed or i'm selling them for something else.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •