Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation: vallinotti's Avatar
    Join Date
    Apr 2009
    Posts
    46

    Egg Beater 11 problems

    Mine has stuck twice, with an awful noise! I opened to see the problem and found that the bearing is damaged and bushing too. Two months of use. I noticed that all came from the factory without any lubrication In my town who used all had the same problem, in total 4 pairs that damn pedal.

    Does anyone know anything about problems with this pedal?

  2. #2
    mtbr member
    Reputation:
    Join Date
    Apr 2005
    Posts
    873
    Anything crankbrothers is junk, period. Unless you're whybotherme
    of course.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Sep 2008
    Posts
    1,915
    Quote Originally Posted by peabody
    Anything crankbrothers is junk, period. Unless you're whybotherme
    of course.

    hahaha... i wouldn't know anything about the 11's. don't own a set.

    i don't like the Joplin.
    My wife's website....
    Allison Mann

  4. #4
    gone for a bike ride
    Reputation: culturesponge's Avatar
    Join Date
    Aug 2007
    Posts
    1,973
    custom 2011 Crank Brother Eggbeater 11 pedals  - 04.01.11 #6235 v2
    the mrs's eggbeater 11 pedals that i sent to CB for custom red ano springs - so i wouldn't have to ruin the soft alloy end caps while checking if there was enough grease - highly recommended

    even though my own eggbeater 11's were 8g over manufacturers stated weight - i couldn't trust CB to use enough grease to install & forget them, so i removed the alloy end caps but they were on so tightly i couldn't do it without gouging them up - fook! - well anyway, it looked like CB used Rock n Roll Super Web Grease for both our pedals & plenty of it at that

    best to check them before install

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •