Results 1 to 4 of 4
  1. #1
    Surfin' da mountain
    Reputation: Cucucachu's Avatar
    Join Date
    Aug 2003
    Posts
    792

    Link me to the thread about the creaking noise from the bottom bracket link

    My 2011 Spot just started making the noise I once read about. I have both lube guns (short nose and long nose) but these pivots won't accept grease. Gonna open it up and manually grease it.

    The noise about drove me nuts on a long grind the other day. Gotta fix it - gotta fix it now!

  2. #2
    mtbr member
    Reputation: ifouiripilay's Avatar
    Join Date
    Nov 2005
    Posts
    331
    I don't know the link but I have a some creaking too. In the processes of checking my pivots I found I had one faulty zerk that didn't allow grease to pass.
    If I recall, people recommended greasing the derailluer hanger and retorqued/ greased the pivots.
    I found some noise coming from the where the brake hose attaches to the lower link just by some dirt between the link and cable.
    I haven't been able to ride my bike after I regreased for the second time. So far i don't hear anything when sitting on it.

  3. #3
    psycho cyclo addict
    Reputation: edubfromktown's Avatar
    Join Date
    Sep 2010
    Posts
    1,956

  4. #4
    mtbr member
    Reputation:
    Join Date
    May 2011
    Posts
    8
    If I recall, people recommended greasing the derailluer hanger and retorqued/ greased the pivots.

    ^ This.

    Take apart everything, clean and re-grease. Check your shock bushes for play, pop them in a vice and give it a wiggle.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •