Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation: bunce's Avatar
    Join Date
    Apr 2009
    Posts
    20

    Anyone having puncture issues with stock wheels on ex8?

    I'm getting a lot of flats, the wholes for the spokes are offset and the rim tape seems to move off them, I've had the bike shop try and fix it also but to no avail.
    Does anyone know of any tricks?

  2. #2
    I hate that name.
    Reputation: blunderbuss's Avatar
    Join Date
    Jan 2004
    Posts
    1,476
    Are you using the blue Schwalbe rimstrip? Cause it sucks. The plastic stretches and stiffens and moves. Change it out for cloth (Velox) or nylon (FSA).
    Worked at Trek/Fisher dealer 2008-2013. Only a little biased.

  3. #3
    mtbr member
    Reputation: bunce's Avatar
    Join Date
    Apr 2009
    Posts
    20
    Yeah, I had it changed out and I'm still having issues. I think gets moved around when the tire is re-installed.

  4. #4
    I hate that name.
    Reputation: blunderbuss's Avatar
    Join Date
    Jan 2004
    Posts
    1,476
    What are you using now? Adhesive cloth shouldn't move. I have in the past with trouble rims completely covered the spoke bed with electrical tape, from bead to bead. Sometimes works out, sometimes not.
    Worked at Trek/Fisher dealer 2008-2013. Only a little biased.

  5. #5
    mtbr member
    Reputation: bunce's Avatar
    Join Date
    Apr 2009
    Posts
    20
    right now I have 2 layers of cloth tape and a heavy duty tube, it seems to be holding for now but I haven't been for a ride yet, hopefully I can report back later today

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •