Results 1 to 3 of 3
  1. #1
    likes bicycles
    Reputation: vitale232's Avatar
    Join Date
    Jun 2007
    Posts
    554

    V1.5 Covert - Slight play in linkage

    I've got a V1.5 Covert bought back in 2008. While putting it up today, I felt the slightest amount of play as I unloaded the rear. Lightly lifting the rear reveals a slight popping feel that's detectable throughout the bike. You can even feel it on the handlebars.

    After spending about an hour trying to chase it down, I'm fairly certain it's the forward most shock mount. Perhaps the bushing became rounded out or something? I'm not that familiar with suspension linkage.

    First up, has anyone else come across this? If so, how'd you fix it? I was planning on replacing the bearings and hardware this winter, but maybe I should fast forward those plans. Do you think new hardware could take care of the issue? Student budget, so I don't want to just start throwing new stuff on there. Also, should I park it until it's all sorted?

    Thanks!

  2. #2
    mtbr member
    Reputation:
    Join Date
    Aug 2005
    Posts
    1,591
    Its probably a shock bushing, you can order the bushing and do it yourself, but most shops stock the part and will probably do it for $20 or so. Its a pretty quick fix.

    You can still ride it, once the bushing is worn, it won't get much worse.
    2013 Transition TransAM 29er
    2011 Yeti 303R DH
    2012 Banshee Spitfire V1.5

  3. #3
    likes bicycles
    Reputation: vitale232's Avatar
    Join Date
    Jun 2007
    Posts
    554
    Sweet. I'll take her by the local Transition dealer for a little slice of love

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •