Results 1 to 4 of 4
  1. #1
    Dawgwalker
    Reputation:
    Join Date
    Apr 2006
    Posts
    202

    X9 Trigger quit shifting

    Ending up single speed out of the trail today because my '09? X9 trigger suddenly would not shift beyond the second cog.
    To elaborate I had only the shift from the smallest to the second cog on rear.
    Everything was fine until suddenly around mile 16 the upshift paddle (one that shifts to bigger cog) had no cable pull. The other paddle dropped the cahin to the first cog and I could only get to those two.

    First ride since cable change so I expect a spring has come loose but want any speculation on how to approach the repair. No shop in town and I typically do my own work.
    2011 Vassago Jabberwocky
    2008 Turner Sultan
    2007 Dean Colonel 29r SS
    2003 Titus Switchblade 650b
    1995 Litespeed Obed

  2. #2
    mtbr member
    Reputation: Qfactor03's Avatar
    Join Date
    Dec 2005
    Posts
    770
    Definitely take a peak inside. I believe there's a coiled flat spring that looks like an old burner off of an electric stove. If the fixed end popped out of it's retainer, it will unwind and I imagine what your experiencing could be the result.

  3. #3
    Dawgwalker
    Reputation:
    Join Date
    Apr 2006
    Posts
    202

    X9 Trigger

    Got it fixed for now.
    Seems tightening the top screw was tightening the coil spring or other henderance.
    The lever side was loose and experimenting with top side and bottom side bolts moved the spring into an acceptable range.
    Hope it is permanent.
    2011 Vassago Jabberwocky
    2008 Turner Sultan
    2007 Dean Colonel 29r SS
    2003 Titus Switchblade 650b
    1995 Litespeed Obed

  4. #4
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    308
    as an update is your shifter still working? mine has developed the same scenario

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •