Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2010
    Posts
    3

    sumpy 2011 expert BIG problems

    I recently bought a 2011 specialized expert carbon. I have had three problems after my first 150 miles of light cross country fire roads. Seriously this is a little out of control for a 4500 dollar bike.

    The brain faid control does not adjust anymore. It just spins and spins when i try to adjust it.

    The fork doesn't adjust 30mm as advertised but 10.

    The shifter Sram x9 for the front derailer is now stuck.

    Has anyone had these problems before?

    thsnk

  2. #2
    mtbr member
    Reputation: GTR2ebike's Avatar
    Join Date
    May 2010
    Posts
    1,881
    Their have been quite a few reports recently of the brain dial continuously spinning, I was at my local shop this week and noticed on the test bike the brain spins 7 revolutions before stopping, 2 clicks per revolution.

    The other things I have no real idea. My only two suggestions would be the check the pressure in the fork and take it back to the shop.

    How did you like the bike before the problems started?

  3. #3
    mtbr member
    Reputation:
    Join Date
    May 2010
    Posts
    33
    Yer my front shifter did the same apparently there was a issue in manufacture with a batch of shifters. All so my saddle was making all sorts of noises due to the rail moving at the interface with the saddle body.Everything was replaced under warranty all good now.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Oct 2010
    Posts
    3
    wow. i just noticed my saddle does the same thing.

    I do have to say. This bike really rode good (for a short time) and i am looking forward to riding it once all of these problems are fixed. I am a little nervous about how quickly it all broke down. I wonder if in two years i am going to have to spend a huge amount of money fixing brain parts once the warranty runs out.


    Has anyone else had issues like this with the brain? It still functions but it def isnt adjusting anything.

  5. #5
    mtbr member
    Reputation:
    Join Date
    Mar 2010
    Posts
    14
    Need to send your Brain in to get fixed. I had two of them do the same thing. The last one the LBS sent it back to Specialized and they said they had some that did not get tightened from the factory. Seems to be working now. Not many miles I got on it since I got it back. Specialized warranty will take care of it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •