Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: bn_acyclist's Avatar
    Join Date
    Jun 2006
    Posts
    130

    Epic rear shock. Anyone had this happen?

    I was adjusting the rebound on the Epic Brain (AFR shock, 2007 S-works Epic), turned it all the way to find if i was going all the way slow or all the way fast. Turned out to be slow, but after that I lost all adjustment. The dial would spin infinintly one way or the other but would not control the rebound at all. Now it's stuck on full slow. Has this happend to anyone else?

  2. #2
    mtbr member
    Reputation: tonys102's Avatar
    Join Date
    Oct 2005
    Posts
    462
    Sounds like you have found the problem where there are a couple of ball bearings which sit inside the top cap, if they come out of the recesses where they are supposed to be, then it jams the dial!! Not sure how it's fixed - I think take the top cap off and move the bearings into position and screw the cap back on.. My LBS fixed mine when I had all sorts of problems with the Brain on my Stumpy!!
    Building: ​Boardman 2010 HT Pro
    Current Joy: '11 Giant Anthem X
    Previous Joy: '09 Commencal Meta 5 VIP

  3. #3
    mtbr member
    Reputation: bn_acyclist's Avatar
    Join Date
    Jun 2006
    Posts
    130

    Update.

    So it turns out I spun the cliker past the stop and broke something. With a race comming this weekend, 24 hrs. Old Pueblo I wasn't sure if I was going to be there with my new S-works. Just got my back up bike tuned and ready. However, Specialized has come to the rescue. They are shipping a shock and my bike should be up and running by Thursday. Obviously everyone on this post has a reason for buying specialized but for me their customer service is world class. Also my LBS (Red Rock Bicycle Co.) is dedicated to facilitating this cause. Thanks to both.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •