Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation:
    Join Date
    Apr 2007
    Posts
    2

    05 Stumpjumper FSR 120 shock link rubbing

    Looks like the shock is bottoming out and the frame is rubbing on the inside of the shock linkage?!? Has anyone ever seen this happen? Seems like I have a defective shock linkage? The rubbing is occurring on both sides also.
    Here a picture, sorry its so blurry!
    scrapeRside

  2. #2
    mtbr member
    Reputation:
    Join Date
    Mar 2005
    Posts
    44
    Quote Originally Posted by stinkpalm
    Looks like the shock is bottoming out and the frame is rubbing on the inside of the shock linkage?!? Has anyone ever seen this happen? Seems like I have a defective shock linkage? The rubbing is occurring on both sides also.
    Here a picture, sorry its so blurry!
    scrapeRside
    Yep. that's a known issues with the 05s. Spech. redid the linkage mid year to resolve the issue. I have the same issue my frame (05 Sworks) too, but my guy at my shop (grew up with him) says its nothing to worry about. You should be able to get a new linkage from your shop, but once the knicks are there, whats done is done.

    punga!

  3. #3
    mtbr member
    Reputation:
    Join Date
    Apr 2007
    Posts
    2
    Cool, thx a ton for the reply. I could've sworn I remembered reading about the issue before, but I couldn't remember where I read it! Looks like I'm headed over to the shop after work!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •