Results 1 to 25 of 25
  1. #1
    Cleavage Of The Tetons
    Reputation:
    Join Date
    Jan 2004
    Posts
    4,830

    Is the site SUPER glitchy, slow, and messed up a little?..

    For anyone else? It's worst on the iPad, but all OS I have work like crap.
    "We LOVE cows! They make trails for us.....

    And then we eat them."

  2. #2
    AZ
    AZ is offline
    banned
    Reputation: AZ's Avatar
    Join Date
    Apr 2009
    Posts
    19,997
    Yes. Quick navigation glitches, pages not loading, intermittently slow, the photo uploader still not working.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jan 2013
    Posts
    703
    Been here nearly two years. If it weren't for the abundance of content I would have given up after a week. This site SUCKS so bad on a technical level. Days to load pages... and they don't giver a damn, advertisers keep giving them money so why bother providing US with a good user experience?

  4. #4
    Cleavage Of The Tetons
    Reputation:
    Join Date
    Jan 2004
    Posts
    4,830
    The advertisers should seriously request refunds.
    "We LOVE cows! They make trails for us.....

    And then we eat them."

  5. #5
    mtbr member
    Reputation:
    Join Date
    Nov 2010
    Posts
    7
    The site is so slow and glitchy compared to every other site I visit, it's really incredible; reminds me of the days of being on dial up.

    While they obviously bring in a lot of advertisers they could be doing a lot better. If other visitors are anything like me, the page views are half of what they should be because I often just give up and go browse another site instead.

  6. #6
    Cleavage Of The Tetons
    Reputation:
    Join Date
    Jan 2004
    Posts
    4,830
    It's really awful.
    Francois, (or Gregg), is it just a matter of new servers?
    You could do a donation link or something.
    I think it is slower (and jumpier) now than in 2004, and that's just insane.
    You guys could be blowing a good thing if it stays this way.

  7. #7
    mtbr member
    Reputation:
    Join Date
    Jan 2014
    Posts
    57
    Getting rid of the Facebook Connect plugin would speed things up greatly.

    Every time I open a new page on this site I have to wait 30-45 seconds for Facebook connect to load in the header before I can click anything else on the page.

    This includes clicking REPLY and trying to type in the text box. It doesn't work until Facebook Connect has loaded.

  8. #8
    mtbr member
    Reputation: d365's Avatar
    Join Date
    Jun 2006
    Posts
    1,322
    I came here to complain as well, but this seems like an appropriate thread to jump in on.

    I can open up an activity window, that shows what's trying to load, and it seems that - openxtracker.com is what is consistently holding things up for me.

    anyway they need to stop it with the openxtracker.com bull****. some days it is so slow, I just go somewhere else to get my mtb pron.

  9. #9
    Cleavage Of The Tetons
    Reputation:
    Join Date
    Jan 2004
    Posts
    4,830
    Good eye. That does seem like a no brainer.
    NOBODY really wants their nerd forums spilling over into their facespace, I would think.
    Ditch that sh!t pronto.
    "We LOVE cows! They make trails for us.....

    And then we eat them."

  10. #10
    mtbr member
    Reputation:
    Join Date
    Jan 2014
    Posts
    57
    It is just really sad the only way I can enjoy looking at this site is via tapatalk on my phone because the real website is so clunky.

  11. #11
    Don't Worry Be Happy
    Reputation:
    Join Date
    Apr 2008
    Posts
    29
    The site is very slow because, I believe, some of the advertising banners is drawing a lot of resources.
    It would be great if you could rework their programming so the site would work smoother, please.


    Peace!

  12. #12
    mtbr member
    Reputation:
    Join Date
    Jan 2014
    Posts
    57
    Quote Originally Posted by Stark View Post
    The site is very slow because, I believe, some of the advertising banners is drawing a lot of resources.
    It would be great if you could rework their programming so the site would work smoother, please.


    Peace!
    The ads, as far as I can tell, are actually loading pretty quickly.
    For me on my 30mb down connection I see the page pretty much load instantly (visually) including ads. Chrome still indicates it is loading though and nothing is clickable for 45 seconds or so. Then, just as soon as the Facebook Connect graphic at the top of the page finally loads, the page finishes loading within a few MS afterwards and everything is fine. It is either the Facebook Connect plugin or the facebook connect server slowing the process down. It is a blocking javascript code that has to load BEFORE anything else can load after it.

  13. #13
    mtbr member
    Reputation: Dirtrider127's Avatar
    Join Date
    Sep 2010
    Posts
    298
    Amazing so many post just today about this web site. I was going to post a new thread complaining but many others are seeing the same poor performance. It's getting not worth the click to come here
    San Diego needs singletrack

  14. #14
    dvo
    dvo is offline
    mtbr member
    Reputation: dvo's Avatar
    Join Date
    May 2004
    Posts
    385
    Seems to have gotten much worse in the last 24-48 hours.

  15. #15
    mtbr member
    Reputation:
    Join Date
    Oct 2010
    Posts
    376
    It's been pretty bad for me the past week but as others have said, noticeably worse in the last day or two.

  16. #16
    mighty sailin' man
    Reputation: MiniTrail's Avatar
    Join Date
    Jan 2008
    Posts
    4,718
    the autoplay adds aren't helping
    Quote Originally Posted by davidarnott
    wheelies, beyond being the best way over any sort of obstacle, both above or below, are are the steedliest expresstion of joy

  17. #17
    mtbr member
    Reputation:
    Join Date
    Nov 2011
    Posts
    2,308
    From the other slow thread:
    I'm seeing that it takes a while for the page to read openxtracker.com. Looks like it is some sort of ad tracker site.

    Adding www.openxtracker.com to my host file helped a lot.
    127.0.0.1 www.openxtracker.com

  18. #18
    swag ho Administrator
    Reputation: francois's Avatar
    Join Date
    Aug 1996
    Posts
    18,335
    It should be fixed now. It was that openxtracker indeed. It is banned!

    Thanks all for helping track this one down.

    fc
    IPA will save America

  19. #19
    Cleavage Of The Tetons
    Reputation:
    Join Date
    Jan 2004
    Posts
    4,830
    That Facebook connect thing is still not working properly.
    Any real reason to have it?

    Thanks for addressing this!
    "We LOVE cows! They make trails for us.....

    And then we eat them."

  20. #20
    mtbr member
    Reputation:
    Join Date
    Jan 2013
    Posts
    703
    Quote Originally Posted by rideit View Post
    That Facebook connect thing is still not working properly.
    Any real reason to have it?

    Thanks for addressing this!


    $$$$$$$$$$$$

  21. #21
    Cleavage Of The Tetons
    Reputation:
    Join Date
    Jan 2004
    Posts
    4,830
    Yeah, of course, but who is getting what for that button?
    Where, exactly, would the revenue stream come from?
    "We LOVE cows! They make trails for us.....

    And then we eat them."

  22. #22
    swag ho Administrator
    Reputation: francois's Avatar
    Join Date
    Aug 1996
    Posts
    18,335
    Facebook Connect.

    It's a way of logging in with one click if one is already logged in on Facebook.

    Also, it provides a way of 'liking' a thread so it shows up on a Facebook wall.

    What part about it is not working?

    fc
    IPA will save America

  23. #23
    Cleavage Of The Tetons
    Reputation:
    Join Date
    Jan 2004
    Posts
    4,830
    Basically, the entire site is completely constipated until the FB connect button lights up.
    Try it on a non office computer, you will see. It's enough to navigate away from the site, which is not good.
    Thanks.

  24. #24
    mtbr member
    Reputation:
    Join Date
    Jan 2014
    Posts
    57
    Facebook connect was loading faster today than it was days prior but it was still making things tough for me earlier today.

  25. #25
    mtbr member
    Reputation:
    Join Date
    Oct 2010
    Posts
    191
    Like others, I came here to see if anyone else saw what I was seeing, sure enough allot of you are (iPad pad user here). The site is real slow, jumps around, then when you click on something the site jumps and brings up something else. Very frustrating Like others said if there wasn't so much content here I would go else where. Roadbikereview is just as bad, maybe controlled by the same people? It started with roadbikereview and then mtbr followed, hmmm.... Everything went to heck when they upgraded a year or so back. Bikeforums and EVERY OTHER WEBSITE works great!

Similar Threads

  1. Admin: Site is slow
    By Technician in forum General Discussion
    Replies: 12
    Last Post: 11-04-2013, 08:21 AM
  2. Slow site performance...
    By Nubster in forum Site Feedback/Issues
    Replies: 21
    Last Post: 06-21-2013, 12:40 PM
  3. MTBR site super slow - is it just me?
    By jkirkpatri in forum Site Feedback/Issues
    Replies: 7
    Last Post: 09-07-2012, 06:56 AM
  4. Super Slow Motion MUni
    By unigeezer in forum Videos and POV Cameras
    Replies: 0
    Last Post: 07-09-2012, 11:52 AM
  5. Site is slow after the upgrade
    By perttime in forum Site Feedback/Issues
    Replies: 1
    Last Post: 06-11-2011, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may edit your posts
  •