Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: L3ONNOEL's Avatar
    Join Date
    May 2012
    Posts
    43

    Rockshox Pike Race

    Today I bottomed out my Pikes and they have started making a clicking noise. It sounds like it is coming from the left leg with the spring, or the crown/ top turny thing that connects to the handlebars. Is this going to become a serious problem, and how do I fix this annoyingness?! Thanks for any help

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jan 2004
    Posts
    681
    By the crown/top turny thing, do you mean one of the adjusters on the top of the fork, or the crown/steerer tube that mounts to the frame?

    Because you're posting here, I assume it wasn't a gentle bottom out. Probably a cased jump or something? At any rate, start with the easy stuff first. You need to isolate the problem. I would start by pulling the fork off and check everything for free play (fork steerer, where steerer mounts to crown, fork uppers to fork lowers). You'll also want to check your headset. Make sure the bearings are still ok and everything. If everything seems ok, then I would just grease everything and reassemble it while making sure to torque everything properly. If that doesn't work then it is most likely isolated to the fork leg. Then you will have to pull the fork apart and see what's going on in there. There are instructions on how to do this.

    If you aren't comfortable doing any of this, then take it to a bike shop. They're pretty good at zeroing in on problems. Once you have some more detail on the problem, people can give more useful answers. Good luck.

  3. #3
    mtbr member
    Reputation: L3ONNOEL's Avatar
    Join Date
    May 2012
    Posts
    43
    Yeah its from the steere tube is making the noise. I've pulled the forks off but it stops making the noise, although twice when I hit the steerer tube to see if it was loose it sounded a little loose. Also I'm not sure if this was always. There but where the crown meets the steerer there is a silver metal thing that the headset bearings go on. Not where the bearings go but on the part that touches the crown is cracked. Thanks
    And I don't think its the fork leg because I've heat shrinked the spring so it doesn't hit anything inside its leg, and the noise stops when the forks are off.
    This is the cracked part
    http://www.imgur.com/J2sv9.jpeg
    It had a few small crack all around it
    Last edited by L3ONNOEL; 09-05-2012 at 04:31 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •