Results 1 to 4 of 4

Thread: XTR 980 Pedals

  1. #1
    mtbr member
    Reputation:
    Join Date
    Mar 2004
    Posts
    37

    XTR 980 Pedals

    Hey All-

    I searched thru some theads, but couldnt find any info on this. I recently replaced a set of 970's with a set of 980 pedals. Upon installation had a heck of a time clipping in. Everything is installed as it should be, but there is a ton of friction/interference between the sole of my shoe (Specialized Pro Carbon mtn) and the pedal bodies platform. I guess I could shim the cleats with something (re: Crank Bros sole guards??). There is so much contact/interference I cant clip in most of the time, and when I do, there is zero float.

    Has anyone else experienced this? I called Shimano and they said they have heard of it and offered no solution. Just wondering what folks were doing to circumvent this problem.

    Thanks-

  2. #2
    mtbr member
    Reputation: Rey Recinto's Avatar
    Join Date
    Mar 2005
    Posts
    203

    980 xtr pedals

    I am using the 980 Trail series pedals with my Specialized Comp MTB shoes ( 01117-38420) with Shimano "multi-release" cleats.

    I have not experienced your predicament in clipping in. I have not modified the sole nor removed material from the sole.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Feb 2008
    Posts
    252
    I have the exact same setup as as Rey Recinto with no problems at all. I am also using a set of Spec Trail 120 shoes with no problems. And I have been using them in a very icing New England winter when many of my cleats/ pedals are useless due to the icing. This new combo has been fantastic.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jan 2004
    Posts
    524
    Quote Originally Posted by TrekSErider
    Hey All-

    I searched thru some theads, but couldnt find any info on this. I recently replaced a set of 970's with a set of 980 pedals. Upon installation had a heck of a time clipping in. Everything is installed as it should be, but there is a ton of friction/interference between the sole of my shoe (Specialized Pro Carbon mtn) and the pedal bodies platform. I guess I could shim the cleats with something (re: Crank Bros sole guards??). There is so much contact/interference I cant clip in most of the time, and when I do, there is zero float.

    Has anyone else experienced this? I called Shimano and they said they have heard of it and offered no solution. Just wondering what folks were doing to circumvent this problem.

    Thanks-
    I had this problem with Specialized Comp shoes and 970 pedals although not as bad as you are describing. I dremeled off a bit of the sole (not the part where the cleat attaches but the actual tread part that touches the ground) and all is good.
    Romani ite domum

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •