Results 1 to 9 of 9
  1. #1
    mtbr member
    Reputation: Tarekith's Avatar
    Join Date
    Mar 2005
    Posts
    2,119

    Fix for loose Slayer front hub?

    I remember reading about this when I got my bike, but my issue is now getting worse. The front hub on my 2012 Slayer is always getting loose, defeats the purpose of having a 20mm thru axle with that much play. Anyone ever find a solution to this?
    Tarekith.com

    '12 RM Slayer70, i9 Torch, Flow EX, XT Brakes, 5050 s3.

  2. #2
    mtbr member
    Reputation:
    Join Date
    Dec 2012
    Posts
    221
    is it that the fork won't close enough or that the fork is solid but the hub still moves??

    My rear wheel was like when I got the bike that but after I tightened the two black plastic end caps on the hub everything was nice a stiff.

  3. #3
    mtbr member
    Reputation: Tarekith's Avatar
    Join Date
    Mar 2005
    Posts
    2,119
    Seems like the fork is solid, but the hub still moves. Sometimes I can open up the 20mm levers on the fork and reclose them and fixes it, but only for a minute or two before the hub is loose again. The fork itself is fine, doesn't does this with other wheel sets I've tried it with, just the Rocky hub.
    Tarekith.com

    '12 RM Slayer70, i9 Torch, Flow EX, XT Brakes, 5050 s3.

  4. #4
    ups and downs
    Reputation: rockyuphill's Avatar
    Join Date
    Nov 2004
    Posts
    14,036
    If you have access to a dial micrometer, check the OD of the thru-axle and the ID of the hub. I had a Marz 55 fork that had a 19.5mm axle diameter, and with a very accurately sized 20mm hub, that 0.5mm of difference allowed a lot of hub slop.
    I'm a member of NSMBA and IMBA Canada

  5. #5
    mtbr member
    Reputation: Tarekith's Avatar
    Join Date
    Mar 2005
    Posts
    2,119
    Err, I'm not really a machine shop, so no access to a micrometer unfortunately.
    Tarekith.com

    '12 RM Slayer70, i9 Torch, Flow EX, XT Brakes, 5050 s3.

  6. #6
    mtbr member
    Reputation:
    Join Date
    May 2011
    Posts
    233
    The Wheeltech hubs on the Slayers are horrible, and contrary to the token CF in the hub shell, they might as well be boat anchors. Odds are that if you have properly adjusted the fork clasps, everything is clean, and all things being equal nothing is wonky, then your hub should probably be looked at IMHO. The Wheeltech hubs are rubbish.

  7. #7
    mtbr member
    Reputation:
    Join Date
    Jul 2011
    Posts
    27
    Hey tarekith I had the same problem with my 2012 slayer 50 but it turned out to be that the tolerances on the fox fork were off. Heard this happens sometimes with that fork.Take it to a shop and try on a new wheel with a good hub, if there is play its the fork.

  8. #8
    mtbr member
    Reputation:
    Join Date
    Jun 2012
    Posts
    243
    I too have a 2012 slayer 70 with a wheeltech front hub on the ex500 rim and I have the EXACT SAME PROBLEM. Didn't even take a month of semi-intense riding and the front hub had play that was/is virtually impossible to fix.

    I built a front wheel with an EX500 rim and a hope pro II hub and there is absolutely no play. The issue is certainly the wheeltech hub.

  9. #9
    mtbr member
    Reputation:
    Join Date
    Oct 2013
    Posts
    96
    I have about 800 miles on my wheeltech carbon hub laced to an EX500 and it is as true as the first day and I haven't touched it other than cleaning. Honestly I'm shocked as I'm not light (185) and don't ride smoothly or slowly.. and its a really light build. Probably hit roughly 150 jumps over 5ft in that time.

Similar Threads

  1. Loose Stan's 3.30 Front Hub - Suggestions?
    By itsice in forum Wheels and Tires
    Replies: 5
    Last Post: 09-25-2014, 05:22 PM
  2. 2010 Rocky Mountain Slayer Front derailleur interference.
    By JeffcoHo in forum Rocky Mountain
    Replies: 1
    Last Post: 01-31-2013, 08:25 PM
  3. I have loose wheel bearings up front.
    By Angel of Death in forum Beginner's Corner
    Replies: 8
    Last Post: 12-14-2012, 09:10 AM
  4. Mount vision xm6 2011 loose front hub
    By jackovo_joe in forum Marin
    Replies: 0
    Last Post: 12-07-2012, 08:24 AM
  5. There's a monster loose on the front range
    By MyCol in forum Colorado - Front Range
    Replies: 14
    Last Post: 10-31-2012, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •