Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    38

    Litespeed weld quality

    Hi all, I have been away from Litespeed frames for many years now, I used to drewl over them many years ago. Through a long story, I was finally able to get one. I have an brand new OBED frame and, unfortunately, it is NOT the beautifully made frame like those I used to see. The welds are not even, splotchy, thick in some areas, thin in others (along the same joint!). It looks like a different person welded each piece. Some are better than others, but overall I can't believe what I'm seeing. Is this normal for Litespeed now or did I just get a lemon.

    In addition, my rear triangle is out of alignment by 4mm. The rear wheel has to be dished over to fit right. I had to send the last one back because the rear end was about 1/2 an inch out of alignment (I waited nearly 2 months to receive this replacement frame). I'd expect this from a low budget frame, but a $2000+ Litespeed seems odd. I am in the crap position of trying to figure out whether to just build it up and live with it (bad welds and poor alignment) or try and send it back and wait even longer for a replacement.

    I thought I'd see what y'all thought before I contact them AGAIN. Anyone else run into either of these problems with them before.

  2. #2
    mtbr member
    Reputation: Napfgeist's Avatar
    Join Date
    Jan 2004
    Posts
    116
    that is very surprising to me.
    The welds on my brandnew OBED are very clean:



    How did you measure the alignment of the rear stays - do you have special equipment?

  3. #3
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    38
    Thanks for the reply. My LBS is putting the bike together, not me. They are the ones who are measuring the alignment. As for the welds, I wish that mine looked like those...

  4. #4
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    38
    Well, I decided to keep the damned thing after all. Pretty disappointed, but facing another month or more of a wait would make me insane. Shame, I expected a lot more from Litespeed...

  5. #5
    mtbr member
    Reputation:
    Join Date
    Jan 2008
    Posts
    1
    Litespeed quality does seem to be hit and miss, I had a new obed last year and my sentiments are the same, some of the welds were not of the most consistent quality, the head tube was poorly faced too. I own a cove hummer - current model also built by LS, and I have to say the quality in craftsmanship is stunning.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •