Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jun 2004
    Posts
    75

    Niterider Digital Evolution Charging Problems

    I bought a Niterider Digital Evolution back in the day(about 7-8 yrs ago).

    I noticed i'm getting some gremlins in the system lately(i sent the lighting unit and battery back for a circuit board swap last year). It worked again, but now, the battery doesn't seem to hold a charge. At the 24 hr race, I charged until i saw 4 green LEDs at the top, then tested. Everything was fine, so i packed it in the truck and headed to the 24 hr race.

    First night lap, 5 minutes in, the light would only come on in the low power walking mode. Lucky I had a Light and Motion Stella bar mount, although still scary.

    I ordered a new battery and the night rider inverter for the car charging. The new battery however, does not seem to be charging up. I think it was shipped discharged, but it was in the car charger for the whole weekend and the charger is still flashing green/red for trickle charge, and it's not even in the charging state.

    Does anyone know if the niterider battery needs to be plugged in to the charger only while the engine is running to get charged up? Doesn't seem like my car charger was actually working. It was charging the whole weekend in the car, although more than half the time the car was off/acc mode. How long does the battery need to be pre charged before it can hold a charge?

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jun 2004
    Posts
    75
    Update: Called jensonusa. I have to ship the battery back. It's been on the charger now for 4 days and it's still in trickle charge mode. It must have discharged so much during storage that it can't be charged up again. I'm not happy at all with the Niterider problems lately. I may switch brands and see if i can buy something better.

  3. #3
    Goats Rule!
    Reputation:
    Join Date
    Sep 2007
    Posts
    305
    Those 7-8 year old cells have probably just died of old age. Batteries do wear out. Your replacement was probably a pretty penny too. Get a refund if you can and get a new light. You could also always just have your old battery rebuilt at Batteries Plus or somewhere like that.

    I have a feeling the replacement battery was just really old. I know many people have had problems with NiteRider stuff but I've always had good luck, and I've had plenty of their stuff, including an old Digital 12 Extreme from 1998 that will still run for an hour on the original battery pack. The only time one Trinewt head died I took it in to NR, had it back the next day.

    Some of the old chargers continued to trickle charge the cells so it's a good idea to unplug them after charging to avoid potentially cooking your battery.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Nov 2010
    Posts
    4

    Listen! Evolution Smart

    Problems, problems, problems,...

    I've had nothing but problems with NiteRider.

    I had an Evolution Smart (DUMB) and the first one out of the box was BAD. The next one worked but never more than 20 minutes or less. The charger was bad or the NEW batteries were CRAP! All this was brand new and it didn't work. You have to understand that all this is made in CHINA.

    I've heard other people having trouble with the Evolution's.

    Whatever... after a lengthy battle with NiteRider they coughed up a MiNewt 350 which has nothing in the way of features; it turns on & has a few brightness levels and a blink mode which is temperamental to activate. Everything with it is extra, like a helmet mount. The MiNewt has an O-Ring mount which I HATE!!! I can see having to readjust the lite every time I hit a bump.

    I'm NEVER getting another NiteRider lite. When the MiNewt fails it goes in the garbage!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •