Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jun 2010
    Posts
    102

    Niterider 1800 Indicator Light Question?

    I just purchased a NiteRider Pro 1800 last night. I tested the light when I got home, seemed to work well. The battery indicator was flashing red.

    I fully charge the battery today. When I connected the light and turned it on, the light immediately was showing the right indicator flashing green. I was expecting to at least see the indicator lights showing full charge for at least a few minutes. Is this normal or do I have a bad battery and need to do a return?

    Thanks in advance.

  2. #2
    mtbr member
    Reputation: mtbRevolution's Avatar
    Join Date
    Aug 2012
    Posts
    347
    Quote Originally Posted by vamaro View Post
    I just purchased a NiteRider Pro 1800 last night. I tested the light when I got home, seemed to work well. The battery indicator was flashing red.

    I fully charge the battery today. When I connected the light and turned it on, the light immediately was showing the right indicator flashing green. I was expecting to at least see the indicator lights showing full charge for at least a few minutes. Is this normal or do I have a bad battery and need to do a return?

    Thanks in advance.
    You will get a quicker and precise answer from the people you bought it from. Why don't you give them a call?

    Have you done a runtime test to see if it works properly despite the flashing green indicator? You'd expect this mentioned in the manual that comes with the light set.
    Leonard - All things Xeccon + Beyond
    mtbRevolution.com

  3. #3
    Goats Rule!
    Reputation:
    Join Date
    Sep 2007
    Posts
    306
    It's normal. The 1800 I had last year did it. The two 3600's I've had also do it. NR says to do a complete discharge and charge cycle to calibrate the meter but it's never made a difference with my lights.

    I just accept the flashing fourth LED even though fully charged, don't worry about it and ride.


    Quote Originally Posted by vamaro View Post
    I just purchased a NiteRider Pro 1800 last night. I tested the light when I got home, seemed to work well. The battery indicator was flashing red.

    I fully charge the battery today. When I connected the light and turned it on, the light immediately was showing the right indicator flashing green. I was expecting to at least see the indicator lights showing full charge for at least a few minutes. Is this normal or do I have a bad battery and need to do a return?

    Thanks in advance.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jun 2010
    Posts
    102
    Tried to give it a go. I was down to 3 lights in less than 5 minutes using the medium and low settings. Just returned it and ordered the 2200. I think the 1800 would have been plenty of light but for a little more money picked up the 2200 just for the wider beam.

Similar Threads

  1. Does anyone have the Niterider Pro 1800?
    By Muffinhead in forum Lights and Night Riding
    Replies: 9
    Last Post: 02-15-2014, 09:21 PM
  2. NiteRider Pro 1800 light pictures.
    By Jack Archer in forum Lights and Night Riding
    Replies: 3
    Last Post: 01-02-2013, 06:14 PM
  3. Niterider Pro 1800?
    By VFRLuke in forum Lights and Night Riding
    Replies: 3
    Last Post: 12-11-2012, 03:52 PM
  4. New Niterider Pro 1800 Race LED - Anyone?
    By nando87 in forum Lights and Night Riding
    Replies: 32
    Last Post: 12-08-2012, 06:05 AM
  5. Niterider pro 1800 race
    By DCTILLER in forum Lights and Night Riding
    Replies: 0
    Last Post: 11-30-2012, 10:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •