Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jun 2010
    Posts
    13

    magicshine 816 spot issue - anyone???????

    I have a different problem that someone (hopefully) can help me with. I have a magicshine 816 also, and it worked properly for 6-8 times. Last time I tried to use it, the lights did NOT blink one time like they normally do when you plug it in and the main spot light (the center one) remains lit at a very dim level regardless of the setting. Pressing the button turns the two flood lights on and off and holding it continuously will progressively dim them as it should. No matter what pattern I press the button, the spot light stays dimly lit as long as the battery in plugged in. Anyone know what to do????? Thanks.

    I posted this in the DIY light section also

  2. #2
    night riding enthusiast
    Reputation: GraXXoR's Avatar
    Join Date
    Sep 2011
    Posts
    265
    Quote Originally Posted by golfwizzzzz View Post
    I have a different problem that someone (hopefully) can help me with... [snip] Anyone know what to do????? Thanks.
    These lights come with electronic controllers which are difficult to diagnose and not worth the time/effort.. If I were you, I'd just send it back and get it replaced.
    Click the thumbs up button if you have a thumb...

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jun 2010
    Posts
    13
    The light is more than a year old, so sending it back is not an option. I can try to fix it, or throw it out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •