Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jun 2004
    Posts
    36

    Lezyne SuperDrive problem

    My SuperDrive has decided to go into the charge LED blip all the time. Pulled the battery in hopes of "reset". The light came on for about half a second then back to blip.

    Anybody had this problem with a SuperDrive or another light? Solution?

  2. #2
    mtbr member
    Reputation: Cat-man-do's Avatar
    Join Date
    May 2004
    Posts
    3,666
    Quote Originally Posted by Pippin View Post
    My SuperDrive has decided to go into the charge LED blip all the time. Pulled the battery in hopes of "reset". The light came on for about half a second then back to blip.

    Anybody had this problem with a SuperDrive or another light? Solution?
    If you have another battery ( with fresh charge ) I would try that. If that doesn't change anything I would return the product....Oh, one more thing....use a pencil eraser to clean the battery and electrically contacts on the lamp...or use a Q-tip and some liquid aluminum cleaner ( think auto wheel cleaner ). Either one will work. This might not fix your problem but will still help the light run brighter.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Mar 2012
    Posts
    458
    Why bother, just return the light to the reseller and let lezyne fix it!

  4. #4
    Loves to suffer
    Reputation: freighttrainuphill's Avatar
    Join Date
    Feb 2012
    Posts
    1,161
    I use a USB wall charger to charge my new PowerDrive. I always plug it into the light before plugging the charger into the outlet. Even when the charger is unplugged from the outlet, the light does the charge blink as soon as I plug the charging cord into the light. The blink gets a little brighter and faster when I plug the charger into the outlet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •