Page 25 of 25 FirstFirst ... 15 21 22 23 24 25
Results 601 to 621 of 621
  1. #601
    mtbr member
    Reputation:
    Join Date
    Jul 2008
    Posts
    18
    Received my replacement batteries today after submitting paperwork in September. Thanks for the outstanding support Geoman, not many companies would stand up and handle the situation like you have. You definitely have my future business and I'll do what I can to send others your way.

  2. #602
    No, that's not phonetic
    Reputation: tscheezy's Avatar
    Join Date
    Dec 2003
    Posts
    14,365
    Got mine today. Nice design. I shipped my old ones off... um, I don't recall when. Pretty long ago. I have other lights so I was not put out.
    My video techniques can be found in this thread.

  3. #603
    mtbr member
    Reputation:
    Join Date
    Apr 2009
    Posts
    347
    Still waiting for mine. Hopefully before the month end or i'll have to contact Geoman.
    12' Sir9 Rigid
    11' Jabber Rigid
    10 SJ SS rigid
    10' Swork SS 29er
    10' Tallboy
    08' RM Vertex SS

  4. #604
    mtbr member
    Reputation:
    Join Date
    Sep 2005
    Posts
    12
    My battery showed up yesterday. I think I sent my paperwork in early November.

  5. #605
    mtbr member
    Reputation:
    Join Date
    Apr 2009
    Posts
    347
    Sweet, got my batteries yesterday. Thanks Geoman.
    12' Sir9 Rigid
    11' Jabber Rigid
    10 SJ SS rigid
    10' Swork SS 29er
    10' Tallboy
    08' RM Vertex SS

  6. #606
    mtbr member
    Reputation:
    Join Date
    Dec 2011
    Posts
    28
    I got mine a wee bit back. Great service.
    I've used them a bunch with no problems. Then last week out on a trail ride I was having problems with them turning off or something. They kept cutting out, and i would have to reach and press them on again, but they wouldn't stay on long. Bit of a bugger to do during a fast trail decent.
    I've never had this happen before.

  7. #607
    Fat!Drunk!Slow!
    Reputation: JordyB's Avatar
    Join Date
    Oct 2007
    Posts
    1,403
    I hope my two batteries show up this week, I sent my paper work in middle of Dec to keep the turn around time down. 45ish days will have been a good timing to me!

  8. #608
    mtbr member
    Reputation:
    Join Date
    Apr 2009
    Posts
    15
    I got my batteries yesterday!! I sent mine in a bit later than most. Many thanks to GeoMan as his company really stepped up and took care of fellow riders. I will always use GeoMan and suggest him to everyone looking for lighting!! Thanks again!!

  9. #609
    mtbr member
    Reputation:
    Join Date
    Jan 2006
    Posts
    1
    I am a happy night biker with Lupine and so once and while I read this forum. And there is always a discussion about Geoman, battery and replacement...

  10. #610
    mtbr member
    Reputation:
    Join Date
    Jun 2009
    Posts
    179
    My recall replacement batteries have a problem being plugged into the light head, then if unplugged, and plugged in again something trips and the battery no longer works. I then have to plug the batteries back into the charger to reset them.

    I have given up on this brand of light and the batteries regardless of the customer service.

  11. #611
    mtbr member
    Reputation: Bike_Muchacho's Avatar
    Join Date
    May 2009
    Posts
    158

    Issues: Old Light with new Battery

    Anybody having this problem. I have the new battery, but the original light. With the old battery-light combo. When riding...LED status light was green, then yellow/orange, then red. When charging, the charger LED was red until charged, then it went green.

    With the New battery - Old light combo something is off. When the battery is fully charged and on the bike the status LED is red and stay red until the battery is fully drained. Every once in a while it does go green after a full charge, but eventually it turns red (even though battery still has a hug charge). I've never seen a yellow with this new set up.

    I think the charger works, but I keep taking the battery off the bike early (cause it red!). And when I plug it into the charger, the charger LED stays green. Which probably makes sense, as the battery isn't discharged.

    This is a real pain as I don't know when I am actually low on juice. Will it make it through the next ride? Hard to tell when the status light is always red.

  12. #612
    night riding enthusiast
    Reputation: GraXXoR's Avatar
    Join Date
    Sep 2011
    Posts
    265
    Quote Originally Posted by Bike_Muchacho View Post
    Anybody having this problem. I have the new battery, but the original light. With the old battery-light combo. When riding...LED status light was green, then yellow/orange, then red. When charging, the charger LED was red until charged, then it went green.

    With the New battery - Old light combo something is off. When the battery is fully charged and on the bike the status LED is red and stay red until the battery is fully drained. Every once in a while it does go green after a full charge, but eventually it turns red (even though battery still has a hug charge). I've never seen a yellow with this new set up.

    I think the charger works, but I keep taking the battery off the bike early (cause it red!). And when I plug it into the charger, the charger LED stays green. Which probably makes sense, as the battery isn't discharged.

    This is a real pain as I don't know when I am actually low on juice. Will it make it through the next ride? Hard to tell when the status light is always red.
    It sounds to me as if you have a faulty battery. How much run time do you get from the battery? Have you run the batteries until the light actually goes out? the fact that the light is showing a red light and the charger is showing a green light would suggest that there is a problem with at least one of the cells in your pack.
    Click the thumbs up button if you have a thumb...

  13. #613
    mtbr member
    Reputation:
    Join Date
    Oct 2006
    Posts
    2,621
    It's well known that the new batteries electronics don't usually play nice with the lighthead charge indicator lights. Test the run time length to confirm that all is well.

  14. #614
    mtbr member
    Reputation: rpinata's Avatar
    Join Date
    Jan 2009
    Posts
    254
    What I've found with the new battery-old lighthead is that the connection is tricky. There seems to be a sweet spot while plugging them in to get the proper green light and full function. I usually have to plug and unplug them multiple times to get it to work right.
    Otherwise I see the red light.
    The Dude abides.

  15. #615
    parenting for gnarness
    Reputation: chollaball's Avatar
    Join Date
    Apr 2005
    Posts
    5,784
    I sent my set out in November and got my new ones a few weeks ago. Finally getting around to sending out my other set, but I see the Claim form is no longer on the website. The site says the recall will continue until April 15...can I just send them in using the form for my old set? Anyone have any updated info?
    Thank you.

  16. #616
    Zero Miles from Myself
    Reputation: mrm1's Avatar
    Join Date
    Apr 2007
    Posts
    738
    Quote Originally Posted by Bike_Muchacho View Post
    Anybody having this problem. I have the new battery, but the original light. With the old battery-light combo. When riding...LED status light was green, then yellow/orange, then red. When charging, the charger LED was red until charged, then it went green.

    With the New battery - Old light combo something is off. When the battery is fully charged and on the bike the status LED is red and stay red until the battery is fully drained. Every once in a while it does go green after a full charge, but eventually it turns red (even though battery still has a hug charge). I've never seen a yellow with this new set up.

    I think the charger works, but I keep taking the battery off the bike early (cause it red!). And when I plug it into the charger, the charger LED stays green. Which probably makes sense, as the battery isn't discharged.

    This is a real pain as I don't know when I am actually low on juice. Will it make it through the next ride? Hard to tell when the status light is always red.
    Similar issues here. I have 2 lights, 2 chargers and 2 batteries (both batteries were replaced). Sometimes when "charged" the red light on the light is on from the beginning, but the battery seems to work for at least 1.5 -2 hrs.

    With one charger both batters give a red light when charging and then go green when charged (like with the the old batteries). With the other charger the light is just green even if the battery is discharged ... so it never indicates charging. This happens with both new batteries.

    So faulty charger right? Not so fast. While waiting most of the summer for the replacements I bought a battery (looks like the old ones) off ebay. This battery works perfectly with either charger. It also has a longer run time and interacts with the lights Green / Yellow / Red indicator like it is suppose to.

    Overall I am not impressed with the newer batteries. Shorter run times for me so far. HEAVY. and on my last night ride, one of the straps just fell apart at the transition between positive and negative velcro. So overall, not a good experience.

  17. #617
    mtbr member
    Reputation:
    Join Date
    Oct 2006
    Posts
    2,621
    [QUOTE=mrm1;9054962...With one charger both batters give a red light when charging and then go green when charged (like with the the old batteries). With the other charger the light is just green even if the battery is discharged ... so it never indicates charging. This happens with both new batteries.

    So faulty charger right? ...[/QUOTE]

    It's well known and discussed in this thread that some of the old chargers don't work with the new batteries. Let Geoman know and they will get you a replacement charger.

  18. #618
    mtbr member
    Reputation: wetmtnvalley's Avatar
    Join Date
    Feb 2010
    Posts
    2
    The recall website says to send an email to them. Have you tried that?
    [SIZE="2"]Wet Mtn Valley[/SIZE]
    [SIZE="1"]Pure Paradise[/SIZE]

  19. #619
    Zero Miles from Myself
    Reputation: mrm1's Avatar
    Join Date
    Apr 2007
    Posts
    738
    No ... did not know that about the chargers. Have not follow the thread close enough. Thanks for the update. will try that.

  20. #620
    parenting for gnarness
    Reputation: chollaball's Avatar
    Join Date
    Apr 2005
    Posts
    5,784
    Quote Originally Posted by chollaball View Post
    I sent my set out in November and got my new ones a few weeks ago. Finally getting around to sending out my other set, but I see the Claim form is no longer on the website. The site says the recall will continue until April 15...can I just send them in using the form for my old set? Anyone have any updated info?
    Thank you.
    thanks Geoman for the form!
    recall ends in 6 weeks, if you are a slacker like me.

  21. #621
    GeoMan
    Reputation: GEOMAN's Avatar
    Join Date
    May 2006
    Posts
    1,707
    Thanks Chollaball, are you racing 12 Hours At Night in Prescott this summer?
    Cheers
    GeoMan

    Quote Originally Posted by chollaball View Post
    thanks Geoman for the form!
    recall ends in 6 weeks, if you are a slacker like me.
    GeoMan
    We Ride!
    www.geomangear.com

Page 25 of 25 FirstFirst ... 15 21 22 23 24 25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •