Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    1,124

    So here's a tip....

    Whiskey and programming a TaskLED driver don't mix.

    It makes you forget things, like even though your 6-up XP-G2 array is bright - you shouldn't select 3A as the max drive current.


  2. #2
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    1,124
    welp - smoked one of the 6. Anyone have a good how-to on replacing just one emitter on a 3 up board?

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jun 2011
    Posts
    1,436
    I was wondering how programing worked if you over due the amps.

    Sucks it toasted one. Hows the driver otherwise? Im itching to try one out

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    1,124
    I was using a Hbflex - but the TaskLED user interface is the same across most models that have the bike programming.

    Simple to use, once you've done it a time or 3. Make sure you have the manual printed out and the options you want to program highlighted - a cheatsheet might help.

    For short periods - a couple of seconds, a 1.5A led can take 3A. Unfortunately I had a brain fart, and set the driver to 3A drive current, thinking I was working with XM-L's. XP-G2's are rated at 1.5A max. I set it to high and was evaluating something else when I noticed smoke. then the array flickered, and came back then went out. Woops.

    I found the dead LED and bypassed that particular 3-up board so I could keep playing with it. The driver seems to operate as it did before.

  5. #5
    mtbr member
    Reputation:
    Join Date
    Apr 2009
    Posts
    62
    Easiest way to get an emitter off without professional gear, is to heat the whole board (on a stove or with a heat gun) up until the solder just starts to melt. take it off the heat and quickly slide (flick!) the dead LED off before it cools. Then place a new LED on and reheat until it just starts to move. Take off the heat and let it cool. You may not even need extra solder paste if there's still some solder left on the board. If you don't have paste, then a tiny blob of solder will work. Add flux if you can and keep the blob flat so that you can put the new LED in place.

    Yes you're reflowing the other LEDs each time, but if you're quick and gentle, it won't hurt them (much).

    Or you can use a heat gun from the top side and use aluminium foil to keep the heat away from the good two.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •