Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    413

    Sigma 1606L is buggin me...

    I got a Sigma 1606L DTS (wireless) cycle computer today because it looked slick and i thought i read the Sigma was decent stuff.

    However, the sensor has to be quite high up on the fork in order to be in range.. my old cheap Vetta wireless allowed me to run it low near the brake disc and it always worked great.

    Secondly, youre supposed to push two buttons at the same time to activate the back light. But when i do this, the screen turns to garbled up mess and it crashes and freezes until i take the battery out to reset it. This can't be good...

    I"m going to exhange it tomorrow because the second symptom must be a defect. Also at REI where i got this, there is a Blackburn Delphi 4.0 for the same price. Should i try this one instead?

    Thanks

  2. #2
    mtbr member
    Reputation:
    Join Date
    Aug 2007
    Posts
    270
    Why don't you continue with Vetta?

  3. #3
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    413
    My only complaint w/ the Vetta was the small screen and no backlight. after about 10 months water got in the case and would fog up, etc, so i used REI's year long no-matter-what garuntee to exchange it for something else. They don't carry Vetta anymore so its Blackburn, Cateye, or Sigma.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    413
    Well i decided to go w/ another Sigma, the same unit, and its basically doing the same thing. Everything is great until i activate the back light and it freezes up and crashes. Maybe its a battery issue.. hrm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •