Results 1 to 2 of 2
  1. #1
    Big Damn Hero
    Reputation: CBRsteve's Avatar
    Join Date
    Nov 2010
    Posts
    350

    XC204 - Rear Linkage Problem

    Hey all, so I've been having a bit of an issue with my bike recently. On downstrokes there is a clicking sound which I thought was the bottom bracket going bad on me. Well yesterday when I was picking up my other bike from the LBS I asked the mech to take a look at the KHS and he noticed a bit of side to side movement when he messed with the rear portion of the bike. I'd estimate that it would move about 1/8 inch either way. He narrowed it down to the linkage circled below... anyone know if this is a common issue or how to get a replacement part? I assume KHS would be the only one I can get the part from?

    Life is like riding a bicycle. To keep your balance you must keep moving. ~ Albert Einstein

  2. #2
    Bike Geek
    Reputation: norcalruckus's Avatar
    Join Date
    May 2005
    Posts
    701
    Was it a broken bearing?
    RIP AL DAVIS

Similar Threads

  1. Problem removing upper linkage
    By james beaumont in forum Ibis
    Replies: 6
    Last Post: 02-04-2009, 09:52 AM
  2. linkage/bearing problem or not?
    By muddywings in forum Intense
    Replies: 12
    Last Post: 07-21-2007, 11:30 AM
  3. Help my 7Point9 Shock/Linkage problem
    By thomas_4th in forum Iron Horse
    Replies: 11
    Last Post: 05-18-2006, 11:37 AM
  4. Replies: 6
    Last Post: 03-04-2006, 05:24 PM
  5. ETS-X linkage/rear end...
    By Fixeyfreeride in forum Canadian Bikes
    Replies: 4
    Last Post: 08-24-2004, 05:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •