Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2008
    Posts
    50

    Uzzi VP zerk fitting help!!!

    Anyone used their grease ports on the new VP. I've tried to use the adapter that came with my frame on my grease gun and I can't get it to work. I can get grease to come out of the needle but I can't really get any to go into the zerk fittings. All that happens is it will leak out of the side of the adapter. I've tried unscrewing the end of the grease gun to let the adapter go further in but the same thing happens. Do I need a different adapter or thinner grease? Do I need a different adapter?
    I'm sure that I don't need to grease yet but I would like to be able too when It does need it. Thanks guys.

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    217
    i had the same problem, the turner forum and a very helpful and patient lbs really helped too. find something narrow and unsharp to loosen the bearing in the zerk fitting (just try not to scatch it) and then repeatedly do this followed by fitting the grease gun really snugly against it and trying... ...doesn't work? try again until you go mad or the grease starts purging out the sides =). another suggestion they had was to find a grease gun with a finer point (or carefully grind your current one to more of a point)

  3. #3
    mtbr member
    Reputation:
    Join Date
    Oct 2008
    Posts
    50
    Thanks for the advice. One more question. How do you keep it from coming out of the adapter where it meets the grease gun? Mine just flows out the side instead of the needle.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jul 2011
    Posts
    466
    Question. How do you know if your putting enough grease in the zerks? One link has the grease coming out of the side of the pivots but the other pivot seems sucking all the grease in and not discharging any old grease in the pivots.

  5. #5
    mtbr member
    Reputation:
    Join Date
    Sep 2008
    Posts
    367
    Quote Originally Posted by LGavin View Post
    Question. How do you know if your putting enough grease in the zerks? One link has the grease coming out of the side of the pivots but the other pivot seems sucking all the grease in and not discharging any old grease in the pivots.
    I pump grease until it comes out of the sides of the bearings. Sounds like your pivot is dry/lacking lube.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •