Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation:
    Join Date
    Apr 2006
    Posts
    14

    mojo hd insert bonding failure

    I finally discovered why I had play in the lower link on my hd. It turns out the 'tube' in the frame where the lower link bolts to/through had become unbonded from the frame and was free to rotate and move latterally,hence causing a load of play.

    I suspect it failed because the lower link bearings siezed and I didn't notice .

    Anyway, I have bonded the tube back into place with some araldite and it seems ok so far.

    But I was wondering if anyone else had this problem, and how did you fix it?

  2. #2
    mtbr member
    Reputation: doismellbacon's Avatar
    Join Date
    Sep 2007
    Posts
    1,991
    I had that issue with an early Mojo C and Ibis took care of it.....despite being beyond the warranty, they offered a replacement front tri at no cost, or for a little $ a complete new SL frame.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Sep 2012
    Posts
    202
    Call Ibis-- They will advise what to do... They are the great and will make sure your ride is safe and if there is a problem-- get it corrected...

Similar Threads

  1. 2012 Shimano XT insert question
    By Ctraut5 in forum Brake Time
    Replies: 2
    Last Post: 11-11-2012, 06:10 PM
  2. Oh no. Nipple insert ripped out of Mavic 823 rim.
    By lelebebbel in forum Downhill - Freeride
    Replies: 32
    Last Post: 07-11-2012, 02:52 PM
  3. Replies: 3
    Last Post: 02-21-2012, 06:42 AM
  4. CYA insert - to - bb30
    By emassa15 in forum Niner Bikes
    Replies: 0
    Last Post: 03-11-2011, 08:24 AM
  5. Replies: 0
    Last Post: 02-09-2011, 08:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •