Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    16

    Clicking noise on HD160

    When I'm pushing down on the seat so that the rear shock compresses, I get a "clickin" noise which I so far has been able to locate to the area around the upper shock mount. The sound is not coming from the shock(tried with another shock) or the mounting hardware or the limbochips(changed them aswell). Anyone experienced something similar?

  2. #2
    mtbr member
    Reputation:
    Join Date
    May 2011
    Posts
    946
    Yes, it was the seatpost or quick release. I took the quick release off the frame cleaned, greased, and put it back on. Also cleaned the seatpost and put a thin film of grease on it.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    16
    Thanks. I Will try that, but I am quait sertain it's coming from the upper shock mount.

  4. #4
    mtbr member
    Reputation: brankulo's Avatar
    Join Date
    Aug 2005
    Posts
    1,077
    its hard to localize where the clicking is coming from. even though you think it is coming from shock area, since you eliminated potential causes of noise in there it might be coming from somewhere else as well. i had clicking noise before while climbing and was pretty sure it is the saddle. in the end it was stem plate not torqued properly to hold handlebar.
    HuRa
    architecture and interior design
    website facebook

  5. #5
    Commit or eat sh!t
    Reputation: Cable0guy's Avatar
    Join Date
    Jun 2007
    Posts
    2,376
    Instead of pressing down on the saddle try the top tube. It may rule out the saddle or seatpost areas as source of problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •