Results 1 to 6 of 6
  1. #1
    mtbr member
    Reputation:
    Join Date
    Mar 2011
    Posts
    39

    Blockage in HD seat tube?

    Last night I tried to drop my seatpost down to have a play on a couple of downhill runs, although it wouldn't go all the way down - as though there was a blockage? As I'm running a Lev I didn't have enough spare cable to remove the post to check but wondered if anyone knew what it could be?

    Cheers!

  2. #2
    www.derbyrims.com
    Reputation: derby's Avatar
    Join Date
    Jan 2004
    Posts
    6,788
    I have the 150mm drop LEV on my HD, with top of LEV collar about 2 inches above the seatpost collar. No clearance problems even when the Lev lower is slid all the way down to collar. Get a good look inside, if there is some irregular small blockage in yours, cutting or filing it out of the way probably wouldn't be a structural issue.

  3. #3
    Lightly salted
    Reputation: fuenstock's Avatar
    Join Date
    May 2006
    Posts
    1,218
    What size frame do you have? I have a size small HD 2012 and my 125mm Lev stops about an inch short of full insertiontion into seat tune.

    Quote Originally Posted by philstone View Post
    Last night I tried to drop my seatpost down to have a play on a couple of downhill runs, although it wouldn't go all the way down - as though there was a blockage? As I'm running a Lev I didn't have enough spare cable to remove the post to check but wondered if anyone knew what it could be?

    Cheers!

  4. #4
    mtbr member
    Reputation:
    Join Date
    Mar 2011
    Posts
    39

    Blockage in HD seat tube?

    It's a medium. I've had an email from
    Todd asking for more details. That's CS for you

  5. #5
    mtbr member
    Reputation:
    Join Date
    Mar 2011
    Posts
    39
    Turns out it was glue I think from the seat post insert. All good now.

    Big thanks to Todd from Ibis for getting in touch! Great customer service!

  6. #6
    Lightly salted
    Reputation: fuenstock's Avatar
    Join Date
    May 2006
    Posts
    1,218
    Quote Originally Posted by philstone View Post
    Turns out it was glue I think from the seat post insert. All good now.

    Big thanks to Todd from Ibis for getting in touch! Great customer service!
    Cool. Did they tell you the best way to clear the glue from the seat tube? I wonder if that's what stops my post from full insertion on my size small frame. I never bothered to check since it went in enough for me with the lev post.

Similar Threads

  1. Replies: 10
    Last Post: 02-22-2012, 10:02 PM
  2. brazing fastback seat stays to the side of the seat tube
    By Meriwether in forum Frame Building
    Replies: 7
    Last Post: 12-05-2011, 05:47 PM
  3. Replies: 13
    Last Post: 09-05-2011, 07:43 PM
  4. Giant Reign Seat Tube Seat Post
    By cjsett in forum Giant
    Replies: 5
    Last Post: 01-16-2011, 06:18 PM
  5. Giant Reign 2010 Seat Tube Seat Post
    By cjsett in forum All Mountain
    Replies: 7
    Last Post: 01-16-2011, 06:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •