Results 1 to 5 of 5

Thread: Chain Issue

  1. #1
    mtbr member
    Reputation:
    Join Date
    Jan 2011
    Posts
    15

    Chain Issue

    First things first. New to the forum and mountain bikes. Just bought my first mountain bike a couple weeks ago, Haro Extreme X6. No bashing the bike please, I thought it would be a good place to start. Haven't rode anything without a throttle in a long time but wanted something I could beat up. It appeared to be strong, I'll know soon enough.

    So I'm having fun riding my bike and starting to jump a bit. On the approach, under heavy acceleration (if you will) my chain will slip/skip/change gears/etc. Is there anything I can add, like a guide, to help eliminate this? Thanks for any and all help. It's a 2010 Haro Extreme X6. Hope that is all the info needed, as I don't know anything elseabout it.

  2. #2
    mtbr member
    Reputation: watkinscapital's Avatar
    Join Date
    Sep 2010
    Posts
    129
    Gears adj correctly? Chain length ok?

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jan 2011
    Posts
    15
    Checked and adjusted by Sun & Ski in Houston

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jan 2007
    Posts
    346

  5. #5
    mtbr member
    Reputation:
    Join Date
    Dec 2006
    Posts
    4
    Hi, I had a similar problem on my 2005 Extreme X3. It changed / slipped gears when accelerating, Checked my rear mech, it felt like the spring had weakened so wasn't holding the chain in line. Replaced the rear mech and no more slipping.
    I've also added an E-13 DRS 'cos the chain would jump off the front ring after landing some drops.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •