Results 1 to 4 of 4
  1. #1
    ADIDAB
    Reputation: Steve_N's Avatar
    Join Date
    Sep 2005
    Posts
    577

    Polar S710 HRM - Memory Failed - What to Do?

    G'day All,

    My Polar S710 HRM has recently displayed 'memory failed' and I'm unable to reset it. I've checked and re-checked the user manual and also checked on-line at the Polar website but there's no information.

    It had happened to me once in the past and by shear fluke I was able to reset it, but I can't remember in what order to press the buttons.

    Has anyone else had problems like this with their S-series Polar HRM? How'd you sort it out? Any info. would be greatly appreciated as I have a race next weekend and want to get it sorted before then (and sending it to Polar here in Oz will take too long)!

    Thanks and Cheers!

    Ps. Mod's - if this thread is in the wrong forum, please feel free to move it...
    My LBS | Riding this and this

  2. #2
    mtbr member
    Reputation: sp00kme's Avatar
    Join Date
    Jan 2004
    Posts
    108

    Polar Memory Failed

    Hi there
    did yout get any resolution to this problem? My S725x has just failed with this message.

    thanks for any info

    cheers

  3. #3
    ADIDAB
    Reputation: Steve_N's Avatar
    Join Date
    Sep 2005
    Posts
    577
    Quote Originally Posted by sp00kme
    Hi there
    did yout get any resolution to this problem? My S725x has just failed with this message.

    thanks for any info

    cheers
    Hey sp00kme - I ended up sending it back to the Polar distributor here in Australia and it required the whole motherboard to be replaced (!). Had it done but wasn't cheap, about AU$220 from memory. As they didn't make the 710 anymore they replaced it with a 720i motherboard. Unfortunately, the one they put in had some issues with the altimeter so I sent back again and they replaced it (again) under warranty with another one. Has been right as rain since...
    My LBS | Riding this and this

  4. #4
    mtbr member
    Reputation: sp00kme's Avatar
    Join Date
    Jan 2004
    Posts
    108
    hi, thaks for that. i seemed to resolve the initial Failed message by holding down the Start button until the watch reset itself.

    However, now the unit will not pick up HR from the strap. Everything else works fine including speed etc, but no HR.

    Using it as a cycle speedo for now until i can decide whether to send it to Polar or find some resolution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •