Results 1 to 22 of 22
  1. #1
    Professional Sinecure
    Reputation: Schlubbe's Avatar
    Join Date
    Jan 2004
    Posts
    40

    My 705 - two hour old BRICK

    Software Missing

    Following the instructions I downloaded Garmin's updater software, hooked up my brand new 705, and now it gives me a software missing message when I turn it on. The downloader now says the update file is corrupt.

    Garmin is of course closed. For the holiday weekend. So now I either have a $500 brick for the weekend, or I see just how amenable Cabella's is to taking back this item. As I was the one who hooked a working unit up to garmin's downloader and now it doesn't work, I don't know how willing I would be to take it back. ( I am a retail manager at a different big box store and I'm pretty sure what I would tell me.)

    Anyone have suggestions?

    Schlubb
    Sinecureal Services Ltd. - Nobody Doesn't Better
    (it's Shluh-buh)

  2. #2
    Lucky...
    Reputation:
    Join Date
    Apr 2008
    Posts
    331
    Ummm- "Mr Cabella's employee- this brand new, $500 toy does not work. I would like a replacement, please."

    Cabella's will RTV the 705 (as they should), you'll get a new device, and everyone is happy. The employee in the returns line won't give you a second look. No need to go into the nitty-gritty details, IMHO. Garmin's software bricked your 705, and they should have to replace it (whether the exchange occurs with you or Cabella's is immaterial).

  3. #3
    Professional Sinecure
    Reputation: Schlubbe's Avatar
    Join Date
    Jan 2004
    Posts
    40

    Exactly what happened

    Cabela's didn't even think twice about exchanging it.

    Tell ya this much, I don't plan on using the updater any time soon...

    McSchlubb
    Sinecureal Services Ltd. - Nobody Doesn't Better
    (it's Shluh-buh)

  4. #4
    trail rat
    Reputation: slocaus's Avatar
    Join Date
    Jul 2005
    Posts
    7,694
    Quote Originally Posted by Schlubbe
    Cabela's didn't even think twice about exchanging it.

    Tell ya this much, I don't plan on using the updater any time soon...

    McSchlubb
    When this happened on two different occasions on my 305, I did a hard reset and then ran the updater again, after rebooting my computer, and having no other programs open or USB cables connected, and it reloaded the software fine.

    Given all the issues with the 705, and the thread that the update fixed many bugs, I'd opt for the update myself. But then I am waiting for you guys to solve all these things before I upgrade from my 305.
    CCCMB web - Facebook
    SLO trail maps - conditions

    "The physician heals, Nature makes well" - real fortune cookie

  5. #5
    Lucky...
    Reputation:
    Join Date
    Apr 2008
    Posts
    331
    Quote Originally Posted by Schlubbe
    Cabela's didn't even think twice about exchanging it.

    Tell ya this much, I don't plan on using the updater any time soon...

    McSchlubb
    I have used the updater twice on my 705 with no issues; downloads the update, installs it, and I reboot the 705. Worked flawlessly. The one caveat is I am using the Mac updater; the fact it worked so well on a Mac is somewhat of a miracle, IMHO.

    I would, however, not run the updater until next week when you can get Garmin support on the phone in the event of an issue.

  6. #6
    Professional Sinecure
    Reputation: Schlubbe's Avatar
    Join Date
    Jan 2004
    Posts
    40

    I'll think about it

    I'm going to see if the issues are something that bugs me- I expect I'll want to do the update at some point, but...

    Right now I'm trying to figure out how to put the speed/cadence sensor on (the store only had the model up from the one I returned.) The location they want has the hose from my BRAIN shock in the way, and it isn't something I can move. Might have to forgo the cadence function and just use the speed by mounting it on the seat-stay. Anyone seen this issue? (will post in the specialized forum too)

    schlubb
    Sinecureal Services Ltd. - Nobody Doesn't Better
    (it's Shluh-buh)

  7. #7
    Lucky...
    Reputation:
    Join Date
    Apr 2008
    Posts
    331
    Got a similar issue on my Yeti- the way the rear brake hose mount sits, I can't strap the cadence/speed sensor on.

    I have found the GPS speed/distance to be fine. It is what the system uses by default anyway, so the only time the unit uses the sensor is when it can't see the sky for a long period of time.

    I do miss the cadence somewhat, but not that much, since it's kinda tough to maintain a steady cadence on the trail.

  8. #8
    mtbr member
    Reputation:
    Join Date
    Aug 2004
    Posts
    15
    Quote Originally Posted by Schlubbe
    ( I am a retail manager at a different big box store and I'm pretty sure what I would tell me.)
    So you're saying if you worked there you'd have refused the exchange?

  9. #9
    mtbr member
    Reputation:
    Join Date
    Sep 2006
    Posts
    34
    i just finished the update on the 705...it worked (again, i'm on a mac.) One of the things that i do whenever i mess with firmware on devices is to make sure that I plug it directly into the machine and not via a hub. i did have a similar problem once on a 305 and the hard reset got me back to the original software setup.

  10. #10
    Professional Sinecure
    Reputation: Schlubbe's Avatar
    Join Date
    Jan 2004
    Posts
    40
    I might indeed have refused it...

    Let me explain my thinking-

    It worked fine when it left the store, I hooked it up to the computer and then it didn't work anymore. I may be a prematurely old f@rt, but I'm a person who always tries to take responsibility for my own actions and almost never try returning something I broke. I was feeling like it was something I did that caused it.

    In hindsight, there seem to be several people who have had the same problem, so I know it wasn't just me. And, given the cutthroat fight for business in modern American retail, I probably would have taken it back with a smile, just like this store did.
    Sinecureal Services Ltd. - Nobody Doesn't Better
    (it's Shluh-buh)

  11. #11
    mtbr member
    Reputation: jdr01930's Avatar
    Join Date
    Oct 2006
    Posts
    779
    For the benefit of anyone else who might find their shiny new Garmin Edge 605/705 "bricked" after running the updater, and come across this thread in a google rampage looking for solutions:

    If the unit says "software missing" and you can't do squat with it, call Garmin support and ask then to send you the file Edge705_2.20region.zip.

    It will fix the device and load up the current firmware, even if you can't see your Edge as a mass storage device.

    As of right now, you can't get that file from their website - maybe that will change,

    Ask for the file by name. First time I called, they told me I had to send it back. Some googling revealed this file name as a solution (thanks to gocycling over at the motionbased forums for posting the info!).
    When I called back and specfically mentioned this file name, they found the right info and sent it along.
    '05 Prophet 1000
    '09 F3
    '93 Delta V 700
    '08 F6 Lefty (son's)
    '08 F6 (daughter's)

  12. #12
    mtbr member
    Reputation:
    Join Date
    Jun 2008
    Posts
    1
    Hi!

    I've got the same problem with my Edge 705. I will need it working tomorrow. Can someone send me the file?
    (luisfrf24@sapo.pt)


    Thanx,
    luisfrf24

  13. #13
    mtbr member
    Reputation:
    Join Date
    Jun 2007
    Posts
    447
    Does Garmin do any product testing at all before selling a $600 unit to the public? Seems to be a nice pattern with these guys.
    ... And I Am You,
    And What I See Is Me!

  14. #14
    mtbr member
    Reputation:
    Join Date
    Aug 2008
    Posts
    4

    Garmin 705 Missing software

    I've also got the same problem with my Edge 705. Can someone please send me the file? greg@sierra-corp.com

  15. #15
    mtbr member
    Reputation:
    Join Date
    Aug 2008
    Posts
    4

    Garmin Edge 705 Missing Software

    I've also got the same problem with my Edge 705. Can someone please send me the file? greg@sierra-corp.com

  16. #16
    mtbr member
    Reputation: jdr01930's Avatar
    Join Date
    Oct 2006
    Posts
    779
    Sending it now.... Good luck!
    '05 Prophet 1000
    '09 F3
    '93 Delta V 700
    '08 F6 Lefty (son's)
    '08 F6 (daughter's)

  17. #17
    mtbr member
    Reputation:
    Join Date
    Aug 2008
    Posts
    4

    Software is no longer missing

    Thanks to everyone that helped. Unit works again and I'll have to be very careful the next update doesn't get interrupted.

  18. #18
    mtbr member
    Reputation:
    Join Date
    Jan 2011
    Posts
    1

    Missing S0ftware

    Hi, I may be a few years too late but found this forum after my 705 became a brick. Any chance someone could sent me the Edge705_2.20region.zip file? ceefers@gmail.com thanks in advance.

  19. #19
    trail rat
    Reputation: slocaus's Avatar
    Join Date
    Jul 2005
    Posts
    7,694
    Quote Originally Posted by Ceefers
    Hi, I may be a few years too late but found this forum after my 705 became a brick. Any chance someone could sent me the Edge705_2.20region.zip file? ceefers@gmail.com thanks in advance.
    It is on the Garmin forums. You will likely have to register and sign in if you have not already.
    CCCMB web - Facebook
    SLO trail maps - conditions

    "The physician heals, Nature makes well" - real fortune cookie

  20. #20
    mtbr member
    Reputation: jdr01930's Avatar
    Join Date
    Oct 2006
    Posts
    779
    Ceefers - just sent you the file.
    Sometimes being an email pack rat comes in handy.

    Good luck!
    '05 Prophet 1000
    '09 F3
    '93 Delta V 700
    '08 F6 Lefty (son's)
    '08 F6 (daughter's)

  21. #21
    mtbr member
    Reputation:
    Join Date
    Aug 2008
    Posts
    4
    Also you can call Garmin support at 913-397-8200. Some of the best product support I've ever dealt with.

  22. #22
    trail rat
    Reputation: slocaus's Avatar
    Join Date
    Jul 2005
    Posts
    7,694
    Quote Originally Posted by gjmsd
    Also you can call Garmin support at 913-397-8200. Some of the best product support I've ever dealt with.
    Might be tough to call that from Australia where Ceefers resides.......
    CCCMB web - Facebook
    SLO trail maps - conditions

    "The physician heals, Nature makes well" - real fortune cookie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •