Results 1 to 11 of 11
  1. #1
    mtbr member
    Reputation: dirtbiker's Avatar
    Join Date
    Jan 2005
    Posts
    619

    HRM on 305 not working

    I am new to the GPS system, I recently bought a new Garmin 305 with HRM and have yet to get the HRM to work. Is there a trick to it working, what could I be doing wrong with it? I sorry this is so basic but I thought all I had to do was put the chest strap on and it would sync up with the GPS. Thanks for any help.
    2013 SC Tallboy LTC
    2013 SC TRC
    2012 Jackal
    2014 Heckler

  2. #2
    GeoMan
    Reputation: GEOMAN's Avatar
    Join Date
    May 2006
    Posts
    1,707
    Try a new battery (CR2032, about $2) and re-pair the HRM to the Edge.
    GeoMan
    We Ride!
    www.geomangear.com

  3. #3
    mtbr member
    Reputation: Swimbait's Avatar
    Join Date
    Sep 2008
    Posts
    16
    Quote Originally Posted by dirtbiker
    I am new to the GPS system, I recently bought a new Garmin 305 with HRM and have yet to get the HRM to work. Is there a trick to it working, what could I be doing wrong with it? I sorry this is so basic but I thought all I had to do was put the chest strap on and it would sync up with the GPS. Thanks for any help.

    Did you ever get it to work? I have the exact same problem. I even replaced the battery and still could not get it to work. Then i put a third battery in and read an FAQ on their website that said it wont work if its near a 2.4 mhz wireless signal, so i went to my street and it kind of worked. It would come on and off (still around the signals from neighbors wireless routers). so next im going to take it to the woods and see if it comes on and stays on. Seems strange that it doesnt have a on off button, i have no idea how it works or knows when to come on. will keep you posted.

  4. #4
    Flyin Pig
    Reputation: IvanLasston's Avatar
    Join Date
    Jul 2006
    Posts
    159
    If it kind of worked - have you tried putting water (and salt if the plain water doesn't work) onto the contacts before putting on the HRM?

  5. #5
    Fat boy Mod Moderator
    Reputation: donalson's Avatar
    Join Date
    Apr 2004
    Posts
    2,369
    Quote Originally Posted by IvanLasston
    If it kind of worked - have you tried putting water (and salt if the plain water doesn't work) onto the contacts before putting on the HRM?
    sliva does the trick also (although it is pretty gross to think about)

    sorry no imput on the 305... i'm cheap and run the 50 w/ no GPS
    - Surly Disc trucker
    - '82 trek 560 roadie

  6. #6
    mtbr member
    Reputation:
    Join Date
    Oct 2007
    Posts
    21
    mine worked on first ride, but never again after that. Got the whole package replaced on warranty. Never found out what the problem was.

  7. #7
    mtbr member
    Reputation: dirtbiker's Avatar
    Join Date
    Jan 2005
    Posts
    619
    Sorry just checking this topic again. No i have not ever got the HRM to sync. I did not know that it would not work around a wireless connection. That may be my problem. I will try it and see.
    2013 SC Tallboy LTC
    2013 SC TRC
    2012 Jackal
    2014 Heckler

  8. #8
    mtbr member
    Reputation:
    Join Date
    Aug 2005
    Posts
    5
    I drove myself crazy recently with this same issue. I tried replacing the battery and that did not work. Not sure if you have tried this but do it if you have not. Go to settings - General - Accessories - Heart Rate Monitor- and then Restart Scan. It will look for your monitor strap and should connect.

  9. #9
    mtbr member
    Reputation: dirtbiker's Avatar
    Join Date
    Jan 2005
    Posts
    619
    I am happy to say that mine is working now, I restarted it along with getting the HRM away from the wireless router and it has worked fine since. I am finally happy with the setup.
    2013 SC Tallboy LTC
    2013 SC TRC
    2012 Jackal
    2014 Heckler

  10. #10
    mtbr member
    Reputation: Yorba's Avatar
    Join Date
    Jul 2009
    Posts
    12
    This happened to me this Spring -- after years of solid performance. I tried cleaning the chest strap, changing batteries, etc... I could reset the 305 to work with my wife's Forerunner chest strap, but no luck with mine. I finally ended up getting a new chest strap for about $40 from Amazon. That did the trick and I am back in business.

    I would love to have used this as an excuse to buy a new color 705, but they are just too damn expensive.

  11. #11
    Team Cspine
    Reputation: bulletbob's Avatar
    Join Date
    Apr 2004
    Posts
    492
    This is so simple I hate to mention it because I'm sure you guys must have tried it but mine doesn't connect until I start sweating or just pour a few drops of water between the strap and my skin. Same with a couple of other hrm models I've had, they just need a bit of moisture to start tracking your hr.
    Sorry what?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •