Results 1 to 7 of 7
  1. #1
    mtbr member
    Reputation: gmats's Avatar
    Join Date
    Apr 2005
    Posts
    2,117

    Help Garmin Edge 500 Weirdness

    Aloha,

    I have noticed that my Edge 500 unit is no longer displaying the HR % Max. My heart rate is displaying fine. Also, I often see that % Grade display is 0 and when I am stationary (not moving), my speed display seems to be 0.1 or so MPH.

    I cannot totally confirm but this seems to have started after I did my firmware upgrade. Any ideas on how to re-enable this or get this operational again?

    Thanks so much.

    Aloha,
    g

  2. #2
    Rep Power: Infinity
    Reputation: NateHawk's Avatar
    Join Date
    Dec 2003
    Posts
    11,503
    How does your user profile look? Firmware updates can scramble this information.

  3. #3
    mtbr member
    Reputation: gmats's Avatar
    Join Date
    Apr 2005
    Posts
    2,117
    Thanks Nate,

    Found the answer here:
    https://forums.garmin.com/showthread...-t-show-max-HR

    Guess it's a semi common problem. I've done the fix, we'll see if it does the trick.

  4. #4
    Rep Power: Infinity
    Reputation: NateHawk's Avatar
    Join Date
    Dec 2003
    Posts
    11,503
    Quote Originally Posted by gmats View Post
    Thanks Nate,

    Found the answer here:
    https://forums.garmin.com/showthread...-t-show-max-HR

    Guess it's a semi common problem. I've done the fix, we'll see if it does the trick.
    Yeah, it's pretty common. Doesn't always manifest with the HR issue, but it can show up in other ways. It's why it's always suggested that you back up your user profile and clear your track log when doing a firmware update.

  5. #5
    mtbr member
    Reputation: gmats's Avatar
    Join Date
    Apr 2005
    Posts
    2,117
    Garmin emailed me back. They suggested a "Full Reset". So yes, they have the three finger salute for the devices too..........We'll see if it works..........

  6. #6
    mtbr member
    Reputation: gmats's Avatar
    Join Date
    Apr 2005
    Posts
    2,117
    Quote Originally Posted by gmats View Post
    Garmin emailed me back. They suggested a "Full Reset". So yes, they have the three finger salute for the devices too..........We'll see if it works..........
    Did not work, % HR MAX still not displaying. Booo!! Gonna pursue "upgrading" firmware to an older version........

  7. #7
    mtbr member
    Reputation: gmats's Avatar
    Join Date
    Apr 2005
    Posts
    2,117
    Quote Originally Posted by gmats View Post
    Thanks Nate,

    Found the answer here:
    https://forums.garmin.com/showthread...-t-show-max-HR

    Guess it's a semi common problem. I've done the fix, we'll see if it does the trick.
    Forgot to "Send To Device". Did the trick. Man, what a pain.......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •