Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: armourbl's Avatar
    Join Date
    May 2012
    Posts
    128

    GPSmap 62S stopped showing topo map

    I was on a trip to the Grand Canyon a few weeks ago. First day, the GPS worked great. Second day it was no longer showing the AZ Topo map in the Map view. I didn't change any settings on the unit. Just powered it off the previous day and powered it on the next. Its been that way ever since.

    Anyone know what could cause this and what the fix is?

    ben

  2. #2
    mtbr member
    Reputation:
    Join Date
    Sep 2010
    Posts
    188
    did you run out of memory? another thing that i figured out with the units (and i doubt this has anything to do with the problem you are having) is to recalibrate the compass, this surprisingly solved a lot of problems for me.
    It's all downhill from here.
    (There's a **** of a lot of climbing left.)

  3. #3
    Rep Power: Infinity
    Reputation: NateHawk's Avatar
    Join Date
    Dec 2003
    Posts
    11,503
    Have you done any of the hard or soft reset procedures?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •