Results 1 to 12 of 12
  1. #1
    Bad Case of the Mondays
    Reputation: Jdub's Avatar
    Join Date
    Jan 2004
    Posts
    4,011

    Garmin Edge 520 Question

    Simple question....Once setup, do you have to open Garmin Connect app on your iPhone to get your Edge 520 to connect via Bluetooth?

    I'm having issues getting mine to stay connected to my iPhone, and the only way I can get it to connect at all is by opening the app on my phone. Even then, it doesn't stay connected as I ride.

    I've tried a few things like removing the connection profiles from my phone and the Edge and reconnecting them, but so far nothing has worked. Seems like I shouldn't have to open the Garmin Connect app every time, BT headphones and other devices just automatically connect after setup.

  2. #2
    mtbr member
    Reputation: thecanoe's Avatar
    Join Date
    Jan 2007
    Posts
    1,186
    I donít keep my 520 connected to my phone. I do my ride. Save it to the 520. Then I turn Bluetooth on the phone on, open GC app and then turn Bluetooth on the 520 on. It then syncís and my rides are sent to Strava and RWGPS automatically from the GC app.


    Sent from my iPhone using Tapatalk
    Santa Cruz Tallboy
    Moonlander

  3. #3
    Bad Case of the Mondays
    Reputation: Jdub's Avatar
    Join Date
    Jan 2004
    Posts
    4,011
    I'd like to use the Strava live segments, which again requires the BT connection.

    I can get it to sync my rides like you describe above, but I don't feel like I should have to open Garmin Connect every time I ride once initially setup. So I would like to determine how it behaves for others.

  4. #4
    Armature speller
    Reputation:
    Join Date
    Sep 2004
    Posts
    2,363
    Do you have any "cleaner" type apps running on your phone?
    Could be killing GC when it thinks it hasn't been active for a while?

  5. #5
    Bad Case of the Mondays
    Reputation: Jdub's Avatar
    Join Date
    Jan 2004
    Posts
    4,011
    Quote Originally Posted by NordieBoy View Post
    Do you have any "cleaner" type apps running on your phone?
    Could be killing GC when it thinks it hasn't been active for a while?
    Nope.

  6. #6
    mtbr member
    Reputation: ewarnerusa's Avatar
    Join Date
    Jun 2004
    Posts
    2,587
    Strava live segments do not require a BT connection to the phone during the ride, at least not on my 510. The Edge downloads your starred segments via the BT connection, but once you are logging an activity you do not need the internet connection. The Edge handles any live Strava segment tracking locally.

    My Android does not need the GC Mobile App opened to establish the BT connection. It seems to work as intended with auto-upload happening automatically upon finishing the activity.

  7. #7
    Bad Case of the Mondays
    Reputation: Jdub's Avatar
    Join Date
    Jan 2004
    Posts
    4,011
    Quote Originally Posted by ewarnerusa View Post
    Strava live segments do not require a BT connection to the phone during the ride, at least not on my 510. The Edge downloads your starred segments via the BT connection, but once you are logging an activity you do not need the internet connection.
    Agreed, I was incorrect above. It does seem that the BT connection is required for text / phone call notifications, which is something I want to do. I would expect the 520 to have the same behavior as my BT headphones...Turn them on, it connects and stays connected till I turn them off. My Edge 520 seems to only connect when I specifically open the GC Mobile App, then it loses connection if I put my phone away and take off riding.

  8. #8
    since 4/10/2009
    Reputation: Harold's Avatar
    Join Date
    Dec 2003
    Posts
    20,640
    IME, the fancier the BT device, the flakier the BT connection. Speakers and such seem pretty reliable, though I got a soundbar recently and if I turn off the speaker, I have to re-connect to it every time I want to use it again, which is annoying.

    When it comes to my Edge 520, I generally leave BT off. I only turn it on specifically when I want to upload a ride after I'm done, and I have to initialize everything on my phone, too, because I leave BT off on it unless I specifically want to use it for something.

    I used it ONCE while riding so I could get weather alerts (there was a high risk of tornadoes that day), but I wound up shortening the planned century road ride that day and hung out in a cool bar I rode past during the ride. I did that long before weather alerts were a problem.

  9. #9
    Bad Case of the Mondays
    Reputation: Jdub's Avatar
    Join Date
    Jan 2004
    Posts
    4,011
    So a follow up....

    I followed steps found on the YouTubes (Video here: https://www.youtube.com/watch?v=6EoRFxaF7b0) that show completely removing the existing BT connections from the Edge and the iPhone, turning off WiFi and BT on the iPhone and BT on the Edge, and then restarting each. I did that then went through the pairing process again.

    In an accidental twist, the 12.3 firmware came out right after I did this, so my Edge upgraded to that firmware during the process. Once it was upgraded and reconnected I did a short ride yesterday and appears that the BT connection is now working (at least for one ride). I didn't have to open GC mobile app, and my phone was connected and ride was uploaded automatically.

    Unfortunately, I don't know if it was the repairing process or something that was corrected / changed in the new firmware, but I thought I would post this update for anyone having similar issues.

  10. #10
    chasing simplicity
    Reputation: MattMay's Avatar
    Join Date
    Dec 2013
    Posts
    659
    I get a little iPhone screen popup that asks if I want to connect to GC once my 500 powers up. Must be different on 520.
    I know what it's like to be dead. "To Die & Live In LA."

  11. #11
    mtbr member
    Reputation:
    Join Date
    Oct 2008
    Posts
    171
    I've had the 520 since it was released. I always have my BT on for both my phone and my Edge. I sometimes carry my phone with me, but other times just leave it in the glove box.

    Typically, my ride uploads as soon as I hit save. Every once in awhile the ride won't upload automatically and I have to open GC, which initializes a sync and uploads a ride. I've never had to manually go in and tell it to sync or turn BT on/off to get it to work.

    I think the few times I've had to force it to upload it's because I saved the ride when I wasn't near my phone. I'm guessing it spends 10-20 seconds searching for a device to upload to and then gives up if it doesn't find it. That's just a guess though.

  12. #12
    Bad Case of the Mondays
    Reputation: Jdub's Avatar
    Join Date
    Jan 2004
    Posts
    4,011
    Quote Originally Posted by AMac4108 View Post
    I've had the 520 since it was released. I always have my BT on for both my phone and my Edge. I sometimes carry my phone with me, but other times just leave it in the glove box.

    Typically, my ride uploads as soon as I hit save. Every once in awhile the ride won't upload automatically and I have to open GC, which initializes a sync and uploads a ride. I've never had to manually go in and tell it to sync or turn BT on/off to get it to work.

    I think the few times I've had to force it to upload it's because I saved the ride when I wasn't near my phone. I'm guessing it spends 10-20 seconds searching for a device to upload to and then gives up if it doesn't find it. That's just a guess though.
    Mine probably only auto uploads about once out of 10 times, the rest of the time I have to manually open GC. The strange thing is that my phone shows two BT connections to the Garmin Edge 520, but the Edge doesn't think its connected to my phone until I open GC.

Similar Threads

  1. Garmin Edge 520
    By WR304 in forum GPS, HRM and Bike Computer
    Replies: 708
    Last Post: 3 Weeks Ago, 04:17 PM
  2. Garmin Edge 520 or wait for WAHOO ELEMNT?
    By yzedf in forum GPS, HRM and Bike Computer
    Replies: 27
    Last Post: 06-16-2017, 04:45 AM
  3. Is a Garmin Edge 520 Worth the Money?
    By DrumsXO in forum GPS, HRM and Bike Computer
    Replies: 9
    Last Post: 08-15-2016, 12:08 PM
  4. Best HRM for a Garmin Edge 520?
    By Rotund in forum GPS, HRM and Bike Computer
    Replies: 7
    Last Post: 06-07-2016, 08:31 AM
  5. Garmin edge 520
    By mtnmark in forum Where are the Best Deals?
    Replies: 3
    Last Post: 07-05-2015, 09:09 AM

Members who have read this thread: 47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •